e9029bf48e
PHP 7.1.x builds upon 7.0.x, adding new features (so far) * Iterable type. * HTTP/2 Server Push Support in ext/curl & other ext/curl improvements * Fix inconsistent behavior in $this variable * Square bracket syntax for array destructuring assignment * Create closure from callable * More precise float values * Asynchronous Signal Handling (without ticks) in ext/pcntl. * Additional Context in pcntl_signal Handler NOTE: this is BETA, not suitable for production environment
16 lines
926 B
JavaScript
16 lines
926 B
JavaScript
$NetBSD: patch-sapi_cgi_Makefile.frag,v 1.1 2016/08/04 14:09:03 jdolecek Exp $
|
|
|
|
--- sapi/cgi/Makefile.frag.orig 2015-06-23 17:33:33.000000000 +0000
|
|
+++ sapi/cgi/Makefile.frag
|
|
@@ -4,9 +4,9 @@ $(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(P
|
|
$(BUILD_CGI)
|
|
|
|
install-cgi: $(SAPI_CGI_PATH)
|
|
- @echo "Installing PHP CGI binary: $(INSTALL_ROOT)$(bindir)/"
|
|
+ @echo "Installing PHP CGI binary: $(INSTALL_ROOT)@CGIDIR@/"
|
|
@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
|
|
- @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)$(bindir)/$(program_prefix)php-cgi$(program_suffix)$(EXEEXT)
|
|
+ @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)@CGIDIR@/$(program_prefix)php$(program_suffix)$(EXEEXT)
|
|
@echo "Installing PHP CGI man page: $(INSTALL_ROOT)$(mandir)/man1/"
|
|
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
|
|
@$(INSTALL_DATA) sapi/cgi/php-cgi.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)php-cgi$(program_suffix).1
|