d0554539e3
- Do not remove share/xine, as it's used by xine-lib too. - There's no need to set BUILDLINK_API_DEPENDS for curl anymore, its buildlink3.mk file takes care of the required version. Bump PKGREVISION.
22 lines
581 B
Text
22 lines
581 B
Text
$NetBSD: patch-zz,v 1.1 2007/07/16 10:12:46 xtraeme Exp $
|
|
|
|
--- src/xitk/panel.c.orig 2006-06-29 14:08:13.000000000 +0000
|
|
+++ src/xitk/panel.c 2007-06-07 02:13:51.000000000 +0000
|
|
@@ -152,6 +152,8 @@
|
|
|
|
xitk_unregister_event_handler(&panel->widget_key);
|
|
|
|
+ pthread_join(panel->slider_thread, NULL);
|
|
+
|
|
XLockDisplay(gGui->display);
|
|
XUnmapWindow(gGui->display, gGui->panel_window);
|
|
XUnlockDisplay(gGui->display);
|
|
@@ -368,8 +370,6 @@
|
|
int pos, secs;
|
|
int i = 0;
|
|
|
|
- pthread_detach(pthread_self());
|
|
-
|
|
while(gGui->on_quit == 0) {
|
|
|
|
if(gGui->stream) {
|