pkgsrc/sysutils/xentools411/patches/patch-Config.mk
bouyer 635c6af9fc Add Xen 4.11.0 packages.
Note that there is a bug in 4.11 (also present in recent 4.6 and 4.8)
which causes an infrequent assert failure when running NetBSD PV guests.
The root cause has not been found, but a workaround is inclued which doesn't
seems to have ill effects. See xenkernel411/patches/patch-zz-bouyer
for details.
2018-07-24 13:40:11 +00:00

22 lines
739 B
Makefile

$NetBSD: patch-Config.mk,v 1.1 2018/07/24 13:40:11 bouyer Exp $
--- Config.mk.orig 2018-04-17 19:21:31.000000000 +0200
+++ Config.mk 2018-04-23 16:15:57.000000000 +0200
@@ -31,7 +31,7 @@
# Tools to run on system hosting the build
HOSTCFLAGS = -Wall -Werror -Wstrict-prototypes -O2 -fomit-frame-pointer
-HOSTCFLAGS += -fno-strict-aliasing
+HOSTCFLAGS += -fno-strict-aliasing ${EXTRA_HOSTCFLAGS}
DISTDIR ?= $(XEN_ROOT)/dist
DESTDIR ?= /
@@ -219,6 +219,8 @@
CFLAGS += -Wall -Wstrict-prototypes
+CFLAGS += ${EXTRA_CFLAGS}
+
$(call cc-option-add,HOSTCFLAGS,HOSTCC,-Wdeclaration-after-statement)
$(call cc-option-add,CFLAGS,CC,-Wdeclaration-after-statement)
$(call cc-option-add,CFLAGS,CC,-Wno-unused-but-set-variable)