pkgsrc/security/hydra/patches/patch-aa
adrianp a645ba3258 Update to 5.4
- Make this compile on amd64
- Don't silently look for libraries when we don't need them.  This should fix
  PR 39318
- Add missing depends on apr

Release 5.4
###########
* Fixes to the http modules as some Apache installations are picky
* The MySQL module also works with mysqld-5.0, updated
* Added AS/400 return code checks to pop3 module
* Fixed memory leaks in the http-form module.
* Implemented a proposal by Jean-Baptiste.BEAUFRETON (at) turbomeca.fr to
  check for "530 user unknown" message in the ftp module
* Added a performance patch by alejandro.mendiondo (at) baicom.com. This one
  needs stability testing!
* Beautification to remove compiler warnings of modern gcc
2008-08-31 10:54:52 +00:00

23 lines
873 B
Text

$NetBSD: patch-aa,v 1.4 2008/08/31 10:54:52 adrianp Exp $
--- Makefile.am.orig 2006-05-05 15:10:44.000000000 +0100
+++ Makefile.am
@@ -33,17 +33,12 @@ EXTRA_DIST = README README.arm README.pa
hydra-mod.h hydra.h crc32.h d3des.h md4.h
all: pw-inspector hydra $(XHYDRA_SUPPORT)
- @echo
- @echo Now type "make install"
hydra: $(OBJ)
$(CC) $(OPTS) $(LIBS) -o $(BIN) $(OBJ) $(LIBS) $(XLIBS) $(XLIBPATHS) || echo -e "\nIF YOU RECEIVED THE ERROR MESSAGE \"cannot find -lpq\" DO THE FOLLOWING:\n make clean; ./configure\n vi Makefile <- and remove the \"-lpq\" and \"-DLIBPOSTGRES\" statements\n make\n"
- @echo
- @echo If men could get pregnant, abortion would be a sacrament
- @echo
xhydra:
- -cd hydra-gtk && ./make_xhydra.sh
+ # -cd hydra-gtk && ./make_xhydra.sh
pw-inspector: pw-inspector.c
-$(CC) $(OPTS) -o pw-inspector pw-inspector.c