pkgsrc/www/firefox24/patches/patch-js_src_Makefile.in
ryoon a66ef51f47 Import firefox24-24.1.0 as www/firefox24.
Mozilla Firefox is a free, open-source and cross-platform web browser
for Windows, Linux, MacOS X and many other operating systems.

It is fast and easy to use, and offers many advantages over other web
browsers, such as tabbed browsing and the ability to block pop-up
windows.

Firefox also offers excellent bookmark and history management, and it
can be extended by developers using industry standards such as XML,
CSS, JavaScript, C++, etc. Many extensions are available.

This package tracks 24 extended support release branch.
2013-11-03 04:51:59 +00:00

62 lines
1.6 KiB
Text

$NetBSD: patch-js_src_Makefile.in,v 1.1 2013/11/03 04:51:59 ryoon Exp $
--- js/src/Makefile.in.orig 2013-10-22 06:19:02.000000000 +0000
+++ js/src/Makefile.in
@@ -237,10 +237,14 @@ endif
# ICU headers need to be available whether we build with the complete
# Internationalization API or not - ICU stubs rely on them.
+ifdef MOZ_NATIVE_ICU
+LOCAL_INCLUDES += $(MOZ_ICU_CFLAGS)
+else
LOCAL_INCLUDES += \
-I$(topsrcdir)/../../intl/icu/source/common \
-I$(topsrcdir)/../../intl/icu/source/i18n \
$(NULL)
+endif
ifdef ENABLE_INTL_API
@@ -260,6 +264,7 @@ else
ICU_MAKE = $(MAKE)
endif
+ifndef MOZ_NATIVE_ICU
# - Build ICU as part of the "export" target, so things get built
# in the right order.
# - ICU requires GNU make according to its readme.html. pymake can't be used
@@ -274,6 +279,7 @@ export::
distclean clean::
$(call SUBMAKE,$@,intl/icu)
+endif
endif
@@ -413,7 +419,11 @@ ifneq (,$(MOZ_ZLIB_LIBS)$(MOZ_GLUE_LDFLA
DEFINES += -DUSE_ZLIB
endif
-SHARED_LIBRARY_LIBS += $(ICU_LIBS)
+ifdef MOZ_NATIVE_ICU
+EXTRA_DSO_LDOPTS += $(MOZ_ICU_LIBS)
+else
+SHARED_LIBRARY_LIBS += $(MOZ_ICU_LIBS)
+endif
# Prevent floating point errors caused by VC++ optimizations
ifdef _MSC_VER
@@ -472,6 +482,13 @@ EXTRA_LIBS += -lposix4 -ldl -lnsl -lsock
endif
endif
+# clang 3.3 + -O2 makes jaeger crash in FixupArity
+ifdef CLANG_CXX
+ifndef MOZ_DEBUG
+Compiler.$(OBJ_SUFFIX): CXXFLAGS += -fno-inline-functions
+endif
+endif
+
# An AIX Optimization bug causes PR_dtoa() & JS_dtoa to produce wrong result.
# This suppresses optimization for this single compilation unit.
ifeq ($(OS_ARCH),AIX)