pkgsrc/devel/g-wrap/patches/patch-aa
wiz b8bdace7b4 Update to 1.9.3, from Greg Troxel via pkgsrc-wip.
Changes since 1.3.4:

Version 1.9.3

  - Comes with a compatibility layer that allows GnuCash to be built
    with it.

  - Reverts the enhanced generics support, which was introduced in
    1.9.2, since that currently breaks guile-gnome

  - Bugfixes
    + g-wrap-2.0-guile.pc is now generated correctly, even if the
      internal libffi is used.
    + Types used by constants are now considered when calculating the
      set of referenced types in a wrapset. This bug led to missing code
      and compile errors when a type defined in another wrapset was used
      by only by a constant.
    + On platforms which lack alloca(), the version shipped with
      G-Wrap should now build correctly.

Version 1.9.2

  - Now comes with libffi included, for systems which lack an libffi
    installation

  - SRFI module checks now work correctly, even if you do an in-tree build

Version 1.9.1

 - API change: destruct-value-cg is now named destroy-value-cg

 - Bugfixes
   + A bug in the latent generic code has been fixed
   + The error message for WCP type errors has been fixed

Version 1.9.0

 - Complete rewrite; too many changes to list, see the manual for the
   new GOOPS-based API and the guile-gnome project for an extended
   example.

  - New features:
    + Output arguments
    + Default arguments

  - G-Wrap should be target-language agnostic, like it was in its
    early days.
2004-12-03 17:06:58 +00:00

12 lines
586 B
Text

$NetBSD: patch-aa,v 1.6 2004/12/03 17:06:58 wiz Exp $
--- g-wrap/Makefile.in.orig 2004-10-16 12:27:42.000000000 -0400
+++ g-wrap/Makefile.in
@@ -342,6 +342,7 @@ uninstall-info-am:
install-nobase_gwrapmoduleDATA: $(nobase_gwrapmodule_DATA)
@$(NORMAL_INSTALL)
test -z "$(gwrapmoduledir)" || $(mkdir_p) "$(DESTDIR)$(gwrapmoduledir)"
+ test -z "$(gwrapmoduledir)/ws" || $(mkdir_p) "$(DESTDIR)$(gwrapmoduledir)/ws"
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
list='$(nobase_gwrapmodule_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \