pkgsrc/devel/py-test-relaxed/patches/patch-setup.py
adam c2ad52182a py-test-relaxed: added version 1.0.0
pytest-relaxed provides 'relaxed' test discovery for pytest.

Has it ever felt strange to you that we put our tests in tests/, then name the
files test_foo.py, name the test classes TestFoo, and finally name the test
methods test_foo_bar? Especially when almost all of the code inside of tests/
is, well, tests?

This pytest plugin takes a page from the rest of Python, where you don't have
to explicitly note public module/class members, but only need to hint as to
which ones are private. By default, all files and objects pytest is told to
scan will be considered tests; to mark something as not-a-test, simply prefix
it with an underscore.
2017-11-15 09:23:17 +00:00

21 lines
604 B
Python

$NetBSD: patch-setup.py,v 1.1 2017/11/15 09:23:17 adam Exp $
Open README.rst with proper encoding.
--- setup.py.orig 2017-10-19 03:09:37.000000000 +0000
+++ setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+import io
from setuptools import setup, find_packages
@@ -19,7 +20,7 @@ setup(
url="https://github.com/bitprophet/pytest-relaxed",
author='Jeff Forcier',
author_email='jeff@bitprophet.org',
- long_description="\n" + open('README.rst').read(),
+ long_description="\n" + io.open('README.rst', encoding='utf-8').read(),
packages=find_packages(),
entry_points={