pkgsrc/devel/py-nose/patches/patch-aa
2015-09-30 13:58:15 +00:00

24 lines
872 B
Text

$NetBSD: patch-aa,v 1.4 2015/09/30 13:58:15 jperkin Exp $
Use PKGMANDIR.
--- setup.py.orig 2011-07-30 23:49:15.000000000 +0000
+++ setup.py
@@ -29,7 +29,7 @@ try:
packages = find_packages(),
entry_points = {
'console_scripts': [
- 'nosetests = nose:run_exit',
+# 'nosetests = nose:run_exit',
'nosetests%s = nose:run_exit' % py_vers_tag,
],
'distutils.commands': [
@@ -102,7 +102,7 @@ setup(
license = 'GNU LGPL',
keywords = 'test unittest doctest automatic discovery',
url = 'http://readthedocs.org/docs/nose/',
- data_files = [('man/man1', ['nosetests.1'])],
+ data_files = [('@PKGMANDIR@/man1', ['nosetests' + sys.version[0:3] + '.1'])],
package_data = {'': ['*.txt',
'examples/*.py',
'examples/*/*.py']},