ceb2acbdf7
Gnash 0.8.10 2012/01/30 Improvements since 0.8.9 release are: * Qt4 GUI supports mouse wheel, clipboard, and screen resolution. * Enhanced UI support for script limits (abort popups, user prefs). * BitmapData functions copyPixels(), copyChannel(), perlinNoise() and noise() implemented. * Node id mapping in ActionScript XML class implemented (XML.idMap). * Fix dispatching of Sound.onLoad event, fixing google dict audio. * Fix support for control tags found after last expected frame (#33176). * Fix support for uncompressed sound with gstreamer media handler. * Implement Button.getDepth(), fix button key events. * Fixes to startDrag and stopDrag opcodes. * Implement onSoundComplete() for event sounds (#23020). * Fix MovieClip.onLoad event dispatching and constant pools handling, fixing support for movies generated by the evil Adobe Captivate tool (#33521). * Fix unattached Sound.stop() semantic (#33888) enjoy Super Mario! * OpenVG renderer added. * Improved framebuffer GUI and touchscreen support. * Framebuffer now supports using multiple renderers. * Refactored input device support. * Fix parsing of lossless 16bit bitmaps, fixing support for movies generated by the evil TechSmit Camtasia tool (#34625). * Improved double buffering support for AGG in a framebuffer. * Thumbnailer for SWF files and GNOME2 desktop config for it.
24 lines
1.2 KiB
Text
24 lines
1.2 KiB
Text
$NetBSD: patch-ae,v 1.4 2012/02/16 10:44:54 obache Exp $
|
|
|
|
--- gui/Makefile.in.orig 2012-01-19 19:49:49.000000000 +0000
|
|
+++ gui/Makefile.in
|
|
@@ -1496,8 +1496,8 @@ GUI_SRCS = gnash.cpp \
|
|
@BUILD_QTOPIA3_GUI_TRUE@ $(AM_LDFLAGS) $(am__append_19) \
|
|
@BUILD_QTOPIA3_GUI_TRUE@ $(am__append_22)
|
|
@BUILD_KDE3_GUI_TRUE@kde3_gnash_CPPFLAGS = -DGUI_KDE3 \
|
|
-@BUILD_KDE3_GUI_TRUE@ -DGUI_CONFIG=\"KDE3\" $(AM_CPPFLAGS) \
|
|
@BUILD_KDE3_GUI_TRUE@ $(KDE3_CFLAGS) $(QT3_CFLAGS) \
|
|
+@BUILD_KDE3_GUI_TRUE@ -DGUI_CONFIG=\"KDE3\" $(AM_CPPFLAGS) \
|
|
@BUILD_KDE3_GUI_TRUE@ $(am__append_26) $(am__append_29)
|
|
@BUILD_KDE3_GUI_TRUE@kde3_gnash_SOURCES = $(GUI_SRCS) qt/gui_kde.cpp \
|
|
@BUILD_KDE3_GUI_TRUE@ qt/kde.cpp qt/kdesup.h qt/kde_glue.h \
|
|
@@ -1512,8 +1512,8 @@ GUI_SRCS = gnash.cpp \
|
|
@BUILD_QT4_GUI_TRUE@ qt/Qt4Glue.h $(am__append_36) \
|
|
@BUILD_QT4_GUI_TRUE@ $(am__append_39) $(am__append_42)
|
|
@BUILD_QT4_GUI_TRUE@qt4_gnash_CPPFLAGS = -DGUI_QT4 \
|
|
-@BUILD_QT4_GUI_TRUE@ -DGUI_CONFIG=\"QT4\" $(AM_CPPFLAGS) \
|
|
@BUILD_QT4_GUI_TRUE@ $(QT4_CFLAGS) $(am__append_34) \
|
|
+@BUILD_QT4_GUI_TRUE@ -DGUI_CONFIG=\"QT4\" $(AM_CPPFLAGS) \
|
|
@BUILD_QT4_GUI_TRUE@ $(am__append_37) $(am__append_40)
|
|
@BUILD_QT4_GUI_TRUE@qt4_gnash_LDFLAGS = -export-dynamic
|
|
@BUILD_QT4_GUI_TRUE@qt4_gnash_LDADD = $(GNASH_LIBS) $(AM_LDFLAGS) \
|