This is a very common use-case and thus VTK is on by default. As there are cases where you just need PCL for the data formats and algorithms, it can be disabled. There is another change pending to add Qt support to VTK, which will be inherited here, as I am told the (a?) standard use case for VTK is via Qt. The option is: Either just computations (headless) or the full visualization stuff.
14 lines
422 B
Text
14 lines
422 B
Text
$NetBSD: patch-examples_stereo_CMakeLists.txt,v 1.1 2021/05/07 11:36:29 thor Exp $
|
|
|
|
Support VTK 9, from PR 4262
|
|
|
|
--- examples/stereo/CMakeLists.txt.orig 2020-08-14 12:23:03.000000000 +0000
|
|
+++ examples/stereo/CMakeLists.txt
|
|
@@ -11,7 +11,6 @@ if(NOT VTK_FOUND)
|
|
else()
|
|
set(DEFAULT TRUE)
|
|
set(REASON)
|
|
- include(${VTK_USE_FILE})
|
|
endif()
|
|
|
|
PCL_ADD_EXAMPLE(pcl_example_stereo_baseline FILES example_stereo_baseline.cpp
|