a235c1d1e5
coming with the source. Patch from Michael van Elst in PR 28770.
34 lines
921 B
Text
34 lines
921 B
Text
$NetBSD: patch-ac,v 1.1 2004/12/25 14:00:10 wiz Exp $
|
|
|
|
--- JPEG/Makefile.PL.orig 2003-12-10 23:12:06.000000000 +0100
|
|
+++ JPEG/Makefile.PL
|
|
@@ -5,29 +5,11 @@ my $l = $Config::Config{'lib_ext'};
|
|
|
|
# use ExtUtils::MakeMaker '6.05';
|
|
|
|
-my @local_jpeg = (
|
|
- 'INC' => '-Ijpeg',
|
|
- 'MYEXTLIB' => "jpeg/libjpeg$l",
|
|
-);
|
|
-
|
|
-use Tk::MMtry;
|
|
-
|
|
-if ($Tk::MMtry::VERSION ge '4.007' && try_run("jpeg/has_jpeg.c",['-I/usr/local/include'],['-ljpeg']))
|
|
- {
|
|
push(@args, LIBS => ['-ljpeg'],
|
|
- INC => '-I/usr/local/include',
|
|
DEFINE => '-DHAVE_JPEGLIB_H',
|
|
);
|
|
warn "Using system's -ljpeg\n";
|
|
unlink("jpeg/Makefile.PL");
|
|
- }
|
|
-else
|
|
- {
|
|
- push(@args, MYEXTLIB => "jpeg/libjpeg$l",
|
|
- 'INC' => '-Ijpeg');
|
|
- copy("jpeg/Makefile.maybe","jpeg/Makefile.PL");
|
|
- warn "Building jpeg/libjpeg$l\n";
|
|
- }
|
|
|
|
Tk::MMutil::TkExtMakefile(@args,
|
|
'NAME' => 'Tk::JPEG',
|