pkgsrc/geography/opencpn/patches/patch-src_glu_CMakeLists.txt
bouyer 9c10d11293 The SIGSEGV worked around by patch-src_glu_libtess_sweep.c are in fact
due to a wrong value GLU_TESS_MAX_COORD on NetBSD. See
http://mail-index.netbsd.org/tech-x11/2016/05/25/msg001733.html

Work around this by reordering -I flags so that the local GL/glu.h is used
before the one from the buildlink directory.

While there change build type from debug to release.
Bump PKGREVISION.
2016-05-25 14:38:48 +00:00

16 lines
573 B
Text

$NetBSD: patch-src_glu_CMakeLists.txt,v 1.1 2016/05/25 14:38:48 bouyer Exp $
Make sure to use our glu.h before the base libraries ones.
--- src/glu/CMakeLists.txt.orig 2016-05-25 16:23:41.000000000 +0200
+++ src/glu/CMakeLists.txt 2016-05-25 16:24:01.000000000 +0200
@@ -17,8 +17,8 @@
ADD_DEFINITIONS( " -g -fno-strict-aliasing -O2")
ENDIF(NOT WIN32 AND NOT APPLE)
-INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
-INCLUDE_DIRECTORIES(include)
+INCLUDE_DIRECTORIES(BEFORE ${CMAKE_SOURCE_DIR}/include)
+INCLUDE_DIRECTORIES(BEFORE include)
IF(WIN32)
IF(MSVC)