e37e6d06d1
<rxg@ms25.url.com.tw>, the maintainer of this package). Changes are bugfixes, and use of the native NetBSD sound API instead of OSS emulation.
20 lines
568 B
Text
20 lines
568 B
Text
$NetBSD: patch-al,v 1.2 2000/10/18 11:22:44 rh Exp $
|
|
|
|
--- ../configure.in.orig Sat Aug 23 17:35:40 1997
|
|
+++ ../configure.in Mon Oct 16 21:12:37 2000
|
|
@@ -73,6 +73,15 @@
|
|
DEFINES="-DNO_BYTE_SWAPPING -DOS_$OS_TYPE -DARCH_$ARCH_TYPE"
|
|
;;
|
|
|
|
+ NetBSD)
|
|
+ CC="gcc"
|
|
+ if test "$ARCH_TYPE" = "i386" ; then
|
|
+ CFLAGS_ARCH="-i586 -pipe"
|
|
+ fi
|
|
+ CFLAGS="-O6 -ffast-math -fomit-frame-pointer ${CFLAGS_ARCH}"
|
|
+ DEFINES="-DNO_BYTE_SWAPPING -DOS_$OS_TYPE -DARCH_$ARCH_TYPE"
|
|
+ ;;
|
|
+
|
|
SunOS)
|
|
if test "$CC" = "gcc"; then
|
|
CFLAGS="-O6 -Dinline= "
|