24f6f95528
Libretro is a simple but powerful development interface that allows for the easy creation of emulators, games and multimedia applications that can plug straight into any libretro-compatible frontend. This development interface is open to others so that they can run these pluggable emulator and game cores also in their own programs or devices. DeSmuME is a Nintendo DS emulator.
17 lines
523 B
Text
17 lines
523 B
Text
$NetBSD: patch-desmume_src_frontend_libretro_Makefile.libretro,v 1.1 2018/08/11 12:57:24 nia Exp $
|
|
|
|
Don't pass -O3 unconditionally.
|
|
|
|
--- desmume/src/frontend/libretro/Makefile.libretro.orig 2018-08-07 06:05:43.000000000 +0000
|
|
+++ desmume/src/frontend/libretro/Makefile.libretro
|
|
@@ -451,8 +451,8 @@ else
|
|
CFLAGS += -O2 -DNDEBUG
|
|
CXXFLAGS += -O2 -DNDEBUG
|
|
else
|
|
- CFLAGS += -O3 -DNDEBUG
|
|
- CXXFLAGS += -O3 -DNDEBUG
|
|
+ CFLAGS += -DNDEBUG
|
|
+ CXXFLAGS += -DNDEBUG
|
|
endif
|
|
endif
|
|
|