pkgsrc/editors/joe/patches/patch-ab
adam 01bcad914f Changes 3.7:
* backspace/DEL means 'n' in replace prompt for better emacs
  compatibility
* Menus are now made up of macros instead of options.
* ^T is now a user definable menu system
* Treat \ as a quote character for file I/O.  Now you can edit
  files like !test with \!test
* Print NULs in default search string.  Handle many \s properly.
* Allow backslashes in file names
* Fix %A to print unicode
* Charles Tabony's (vectorshifts's) highlighter stack patch
* ! is relace all in replace prompt
* Turn off UTF-8 when we enter hex mode
* Call ttsig on vfile I/O errors.
* Abort cleanly when malloc returns NULL
* Add reload command to reload file from disk
* Modify configure scrips to use docdir for extra documents and
* Don't use bold yellow, it's bad for white screens
* Fix TeX highlighter: don't highlight "
* Make mail.jsf more forgiving for those of us who still use old UNIX mail
* Fix file rename bugs
* Improve ubop: can reformat a block of paragraphs again.  Reformat
  of adjacent indented paragraphs working again.
* Improve XML highlighter: allow \r in whitespace
2010-06-23 12:52:42 +00:00

20 lines
969 B
Text

$NetBSD: patch-ab,v 1.7 2010/06/23 12:52:43 adam Exp $
--- rc/Makefile.in.orig 2010-06-23 09:05:54.000000000 +0000
+++ rc/Makefile.in
@@ -196,12 +196,12 @@ $(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
install-sysconf_joeDATA: $(sysconf_joe_DATA)
@$(NORMAL_INSTALL)
- test -z "$(sysconf_joedir)" || $(MKDIR_P) "$(DESTDIR)$(sysconf_joedir)"
+ $(MKDIR_P) "$(DESTDIR)$(datarootdir)/examples/joe"
@list='$(sysconf_joe_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f=$(am__strip_dir) \
- echo " $(sysconf_joeDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconf_joedir)/$$f'"; \
- $(sysconf_joeDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconf_joedir)/$$f"; \
+ echo " $(sysconf_joeDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(datarootdir)/examples/joe/$$f'"; \
+ $(sysconf_joeDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(datarootdir)/examples/joe/$$f"; \
done
uninstall-sysconf_joeDATA: