pkgsrc/mail/elm/patches/patch-ac
dholland 748aedba97 DESTDIR support. Use SPECIAL_PERMS. Fix some pkglint. Add missing
manpage link. Fix getline lossage on -current. Wrap the homemade
config.sh substitutions in @@ to make them more robust. PKGREVISION++
2010-04-15 06:50:46 +00:00

26 lines
661 B
Text

$NetBSD: patch-ac,v 1.6 2010/04/15 06:50:46 dholland Exp $
--- nls/Makefile.orig 2005-08-18 12:49:24.000000000 +0000
+++ nls/Makefile
@@ -1,6 +1,6 @@
LANGFILE=LANGS
CATNAME=elm2.5.cat
-GENCAT= gencat/gencat
+GENCAT= ./gencat/gencat
HDIR= ../hdrs
SDIR= C/C/C
@@ -35,8 +35,11 @@ nls-headers: clean $(HFILES)
# same basename, so wait until install to put them somewhere.
all:
-install:
- ./Install $(LANGFILE) $(GENCAT) $(CATNAME)
+install: $(GENCAT)
+ DESTDIR=$(DESTDIR) ./Install $(LANGFILE) $(GENCAT) $(CATNAME)
+
+$(GENCAT):
+ cd gencat && $(MAKE) $(MFLAGS) $(MJ)
$(HFILES): $(MFILES)
gencat/gencat $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@