62b56b94c0
Include code in the Makefile to show how to use the installed .packlist to dynamically generate a PLIST for this package. I couldn't use the solution proposed on tech-pkg since eperl installed some stuff in ${PERL5_SITELIB} under perl-5.00404, but in ${PERL_SITEARCH} under perl-5.6.0. I imagine other modules will also show this difficulty since the Makefile for eperl was generated by ExtUtils::MakeMaker, so I think the .packlist way is the right thing to do.
44 lines
1.9 KiB
Text
44 lines
1.9 KiB
Text
$NetBSD: patch-ab,v 1.1 2000/08/15 01:12:16 jlam Exp $
|
|
|
|
--- configure.in.orig Wed Dec 31 03:22:16 1997
|
|
+++ configure.in Sat Aug 12 04:26:23 2000
|
|
@@ -42,7 +42,7 @@
|
|
AC_ARG_WITH(perl,dnl
|
|
[ --with-perl=PATH force the usage of a specific installed Perl],
|
|
perlprog=$with_perl
|
|
-perlvers=`$perlprog -v | grep version | sed -e 's/.* version //' -e 's/ built.*//' -e 's/ with.*//'`
|
|
+perlvers=`$perlprog -v | grep "This is perl" | sed -e 's/.* version //' -e 's/.* v//' -e 's/ built.*//' -e 's/ with.*//'`
|
|
,
|
|
TMPFILE=/tmp/x.$$
|
|
rm -f $TMPFILE
|
|
@@ -53,7 +53,7 @@
|
|
if test -f "$dir/$perl"; then
|
|
if test -x "$dir/$perl"; then
|
|
perl="$dir/$perl"
|
|
- version=`$perl -v | grep version | sed -e 's/.* version //' -e 's/ built.*//' -e 's/ with.*//'`
|
|
+ version=`$perl -v | grep "This is perl" | sed -e 's/.* version //' -e 's/.* v//' -e 's/ built.*//' -e 's/ with.*//'`
|
|
versionnum="`echo $version | sed -e 's/\.//g' -e 's/_//g'`"
|
|
versionnum=`expr $versionnum - $c`
|
|
echo "$versionnum $version $perl" >>$TMPFILE
|
|
@@ -69,7 +69,7 @@
|
|
PATH_PERL=$perlprog
|
|
AC_MSG_RESULT([$perlprog v$perlvers])
|
|
case $perlvers in
|
|
- 5.003* | 5.004* | 5.005* | 5.006* )
|
|
+ 5.003* | 5.004* | 5.005* | 5.006* | 5.[[1-9]]* )
|
|
;;
|
|
* ) echo ""
|
|
echo "Latest Perl found on your system is $perlvers,"
|
|
@@ -86,6 +86,12 @@
|
|
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/_//'` ;;
|
|
5.00[[3-6]] )
|
|
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/$/00/'` ;;
|
|
+ 5.[[1-9]].[[0-9]][[0-9]] )
|
|
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/\.//'` ;;
|
|
+ 5.[[1-9]].[[0-9]] )
|
|
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/\./0/'` ;;
|
|
+ 5.[[1-9]] )
|
|
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/$/00/'` ;;
|
|
* )
|
|
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/_//'` ;;
|
|
esac
|