pkgsrc/sysutils/amanda-server/patches/patch-af
gdt b4036ff68a Update to 2.5.2p1, provided by Nick Goffee of BBN.
[bugfixes and minor improvements omitted; see NEWS]

Changes in release 2.5.2

   * krb5 auth is working
   * Works with IPv6 address
   * Amanda configuration file changes
         o amanda.conf changes
               + debugging is enabled in the config file
                 see all debug_* config option
               + tapetype 'readblocksize', if maxtapeblocksize is set too
                 larger for your hardware
   * Amanda command changes
         o amadmin: new 'holding list' and 'holding delete' subcommand.

Changes in release 2.5.1p3

   * Works with tar-1.16 and exit status of 1.

Changes in release 2.5.1p2

   * amoverview is working
   * dumptype starttime is working

   * Amanda command changes
         o amtape accept the -o arguments
         o amgetconf --list to list all tapetype, dumptype, holdingdisk
           or interface
         o amgetconf can return a value of a specific tapetype, dumptype,
           holdingdisk or interface

Changes in release 2.5.1p1

   * Remove contrib/sst.

Changes in release 2.5.1

   * Defects found by Coverity scan and Klocwork K7 analysis tools fixed.
   * Works with GNU tar 1.15.91 - work with new gtar state file format.
   * Open SSL encryption support
   * Two new authentication methods: bsdtcp, bsdudp.
   * Unlimited number of DLEs on a client with bsdtcp, rsh and ssh
     authentication methods.
   * Recovery process amrecover uses Secure API. amoldrecover command
     (same syntax and functionality as amrecover command) is provided for
     compatibility with old Amanda releases. amoldrecover command uses old
     amidxtaped/amindexd protocol.
   * Amanda debug files are separated into client/server/amandad and
     are also classified based on Amanda configuration name.

   * Amanda command changes
         o amfetchdump -o is replaced by -O.
         o amcheck -w option does all tests including the tape writable test.
           Use amcheck -t -w to do only the tape writable test.
         o -o command option to override Amanda configuration. See amanda man
           page for details.
         o amgetconf command doesn't write the BUGGY message when a entry
           is not found in the configuration file.

   * Amanda configuration file changes
         o amanda.conf changes
               + amrecover_do_fsf in amanda.conf defaults to yes
               + amrecover_check_label in amanda.conf defaults to yes
               + usetimestamps in amanda.conf to support multiple
                 backup runs in a calendar day.
               + holdingdisk in amanda.conf supports new values:
                 NEVER, AUTO, REQUIRED.
               + amandad_path, client_username and ssh_keys in
                 amanda.conf for ssh/rsh authentication.
         o New amanda client configuration file - amanda-client.conf.
           Different client configuration file can be used for each Amanda
           configuration.
               + gnutar_list-dir and amandates can be specified in
                 Amanda client configuration file - amanda-client.conf
         o .amandahosts format changes to allow use of secure API for recovery.
         o Amanda service entries in xinetd configuration has changed.

Changes in release 2.5.0p1

* Add the 'amtape update' command.

Changes in release 2.5.0

* Communication security/authentication: Kerberos 4/5, OpenSSH
* Data security: Symmetric/Assymetric encrytion algorithms (aesutil
  and gpg encryption),  Encryption can be done on server or client,
  Custom encryption utilities can be used.
* Compression: Ability to add custom compression tools. This is a
  really useful feature especially since it can specified for a DLE.  You
  can use different compression algorithm for images, binaries, ascii files
  and so on.
* Dump images spanning multiple media volumes - Dump images are no
  longer restricted to a single media volume (tape or vtape).  Data restoration
  can be done using amrecover and amfetchdump commands.
* Auto tape labelling - This optional feature is good for disk backups.

Change in release 2.4.5

* new displayunit global option to select the unit use to display number
  k=kilo, m=mega, g=giga, t=tera.
* new amoverview -skipmissed option.

Change in release 2.4.5b1

* holding disk disk use timestamped directory.
* autoflush flush today's dump.
* new bumppercent global option, this should improve bumping criteria,
  the bumpsize is set to a fixed value which can be adequate for small
  and large disk.
* bumpsize, bumppercent, bumpdays and bumpmult can be in a dumptype.
* calcsize support include and exclude like gnutar.
* new 'estimate' dumptype option to select estimate type:
    CLIENT: estimate by the dumping program.
    CALCSIZE: estimate by the calcsize program, a lot faster but less acurate.
    SERVER: estimate based on statistic from previous run, take second but
            can be wrong on the estimate size.
2008-02-15 16:23:09 +00:00

60 lines
2.2 KiB
Text

$NetBSD: patch-af,v 1.7 2008/02/15 16:23:09 gdt Exp $
Remove build-directory library dependencies and link against the ones
installed by amanda-common instead.
--- tape-src/Makefile.in.orig 2007-06-06 19:22:53.000000000 -0400
+++ tape-src/Makefile.in
@@ -108,26 +108,18 @@ PROGRAMS = $(sbin_PROGRAMS)
amdd_SOURCES = amdd.c
amdd_OBJECTS = amdd.$(OBJEXT)
amdd_LDADD = $(LDADD)
-amdd_DEPENDENCIES = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+amdd_DEPENDENCIES = libamtape.$(LIB_EXTENSION)
ammt_SOURCES = ammt.c
ammt_OBJECTS = ammt.$(OBJEXT)
ammt_LDADD = $(LDADD)
-ammt_DEPENDENCIES = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+ammt_DEPENDENCIES = libamtape.$(LIB_EXTENSION)
am_amtapeio_OBJECTS = amtapeio.test.$(OBJEXT)
amtapeio_OBJECTS = $(am_amtapeio_OBJECTS)
-amtapeio_DEPENDENCIES = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+amtapeio_DEPENDENCIES = libamtape.$(LIB_EXTENSION)
am_amtapetype_OBJECTS = tapetype.$(OBJEXT)
amtapetype_OBJECTS = $(am_amtapetype_OBJECTS)
amtapetype_LDADD = $(LDADD)
-amtapetype_DEPENDENCIES = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+amtapetype_DEPENDENCIES = libamtape.$(LIB_EXTENSION)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/config
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
am__depfiles_maybe = depfiles
@@ -416,9 +408,7 @@ libamtape_la_LDFLAGS = -release $(VERSIO
# need to list libamanda twice here, first to override the system library
# routines, and second to pick up any references in the other libraries.
###
-LDADD = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+LDADD = libamtape.$(LIB_EXTENSION) -lamanda
# used for testing only
@@ -433,9 +423,7 @@ noinst_HEADERS = \
tapeio.h
amtapeio_SOURCES = amtapeio.test.c
-amtapeio_LDADD = ../common-src/libamanda.$(LIB_EXTENSION) \
- libamtape.$(LIB_EXTENSION) \
- ../common-src/libamanda.$(LIB_EXTENSION)
+amtapeio_LDADD = libamtape.$(LIB_EXTENSION) -lamanda
all: all-am