39 lines
1.4 KiB
Text
39 lines
1.4 KiB
Text
$NetBSD: patch-bm,v 1.2 2002/08/25 19:23:54 jlam Exp $
|
|
|
|
--- kioslave/http/Makefile.am.orig Fri Jan 18 16:04:23 2002
|
|
+++ kioslave/http/Makefile.am
|
|
@@ -9,19 +9,22 @@
|
|
####### Files
|
|
|
|
bin_PROGRAMS = kio_http_cache_cleaner
|
|
-lib_LTLIBRARIES = kio_http_cache_cleaner.la
|
|
+lib_LTLIBRARIES = libkio_http_cache_cleaner_main.la kio_http_cache_cleaner.la
|
|
kde_module_LTLIBRARIES = kio_http.la
|
|
|
|
kio_http_la_SOURCES = http.cc
|
|
kio_http_la_LIBADD = $(LIB_KIO) $(LIBZ)
|
|
kio_http_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
|
|
|
|
-kio_http_cache_cleaner_SOURCES = dummy.cpp
|
|
-kio_http_cache_cleaner_LDADD = kio_http_cache_cleaner.la
|
|
+kio_http_cache_cleaner_SOURCES = http_cache_cleaner_main.cpp
|
|
+kio_http_cache_cleaner_LDADD = libkio_http_cache_cleaner_main.la
|
|
kio_http_cache_cleaner_LDFLAGS = $(KDE_RPATH)
|
|
|
|
-kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner.cpp
|
|
-kio_http_cache_cleaner_la_LIBADD = $(LIB_KIO)
|
|
+libkio_http_cache_cleaner_main_la_SOURCES = http_cache_cleaner.cpp
|
|
+libkio_http_cache_cleaner_main_la_LIBADD = $(LIB_KIO)
|
|
+
|
|
+kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner_main.cpp
|
|
+kio_http_cache_cleaner_la_LIBADD = libkio_http_cache_cleaner_main.la
|
|
kio_http_cache_cleaner_la_LDFLAGS = -module -avoid-version
|
|
|
|
noinst_HEADERS = http.h
|
|
@@ -29,6 +32,3 @@
|
|
kdelnkdir = $(kde_servicesdir)
|
|
kdelnk_DATA = http_cache_cleaner.desktop http.protocol https.protocol \
|
|
webdav.protocol webdavs.protocol
|
|
-
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|