pkgsrc/graphics/py-goocanvas/patches/patch-aa
drochner 5e5c77be66 trim library search path so that the dynamic version of libpython
is found for building the Python plugin module
(I still think that no Python library needs to be linked in for modules,
but I want to keep the change minimal.)
Inspired by an observation by Mark Davies, see the
"python buildlink3.mk and lib/python2.?/config" thread on tech-pkg.
bump PKGREVISION
2011-04-15 17:14:52 +00:00

25 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.3 2011/04/15 17:14:52 drochner Exp $
Portability fix:
http://bugzilla.gnome.org/show_bug.cgi?id=582057
--- configure.orig 2009-05-10 08:45:29.000000000 +0000
+++ configure
@@ -13126,7 +13126,7 @@ $as_echo_n "checking for Python library
WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+ for i in "$python_path/lib/" ; do
if test -e "$i"; then
python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
if test -n "$python_path" ; then
@@ -13450,7 +13450,7 @@ fi
fi
fi
-if test x$enable_docs == xyes; then
+if test x$enable_docs = xyes; then
if ! $PKG_CONFIG "pygobject-2.0 >= 2.11.3"; then
{ $as_echo "$as_me:$LINENO: WARNING: pygobject-2.0 < 2.11.3; disabling generation of docs" >&5
$as_echo "$as_me: WARNING: pygobject-2.0 < 2.11.3; disabling generation of docs" >&2;}