b53fa27a66
Version 0.8.13 - 18 November 2003 * Add -s/--shadowbuiltin option to warn when overriding a builtin * Add warning when assigning a variable to itself * Add warning when dividing a variable by itself * Add warnings when using a bit-wise operator with the same variable (a & a) * Add warning when passing a constant string to getattr()/setattr() * Add --special option to check for __special__ (reserved) method names and that their signature (argument count) is correct * Add warning for using __getattribute__ in an old-style class * Suppress 'self as first argument' warning for static and class methods * Add --classmethodargs option to specify first argument name for class methods
31 lines
1.1 KiB
Text
31 lines
1.1 KiB
Text
$NetBSD: patch-aa,v 1.3 2003/12/02 23:37:26 recht Exp $
|
|
|
|
--- setup.py~ 2003-11-18 04:50:14.000000000 +0100
|
|
+++ setup.py 2003-11-19 14:42:48.000000000 +0100
|
|
@@ -10,7 +10,6 @@
|
|
|
|
import sys
|
|
import os
|
|
-import tempfile
|
|
|
|
from distutils.core import setup
|
|
from distutils import sysconfig
|
|
@@ -56,8 +55,8 @@
|
|
script_str = '%s %s %s\n' % (py_exe, checker_py, arg_str)
|
|
script_suffix = '.bat'
|
|
|
|
- LOCAL_SCRIPT = 'pychecker' + script_suffix
|
|
- LOCAL_SCRIPT = os.path.join(tempfile.gettempdir(), LOCAL_SCRIPT)
|
|
+ LOCAL_SCRIPT = 'pychecker' + sys.version[0:3] + script_suffix
|
|
+ LOCAL_SCRIPT = os.path.join('./', LOCAL_SCRIPT)
|
|
remove_file(LOCAL_SCRIPT)
|
|
|
|
try :
|
|
@@ -78,7 +77,6 @@
|
|
author_email = "pychecker@metaslash.com",
|
|
url = "http://pychecker.sourceforge.net/",
|
|
packages = [ 'pychecker' ],
|
|
- data_files = [ (install_dir, DOC_FILES) ],
|
|
scripts = [ LOCAL_SCRIPT, ],
|
|
# classifiers was added in Python 2.3, but needed for PyPI
|
|
#classifiers = CLASSIFIERS,
|