pkgsrc/cross/nios2-binutils/patches/patch-ai
mef 14bb9862e2 (pkgsrc)
Switch from Codesourcery to GNU FSF
(Upstream 2.23.2 to 2.24.0)
- binutils
  * Objcopy now supports wildcard characters in command line options that take
    section names.
  * Add support for Altera Nios II.
- gas
  * Add support for the Texas Instruments MSP430X processor.
  * Add -gdwarf-sections command line option to enable per-code-section
    generation of DWARF .debug_line sections.
  * Add support for Altera Nios II.
  * Add support for the Imagination Technologies Meta processor.
  * Add support for the v850e3v5.
  * Remove assembler support for MIPS ECOFF targets.
- ld
  * Add LOG2CEIL() builtin function to the linker script language
  * Add support for the Texas Instruments MSP430X processor.
  * Add support for Altera Nios II.
  * Add support for the V850E3V5 architecture.
  * Add support for the Imagination Technologies Meta processor.
  * --enable-new-dtags no longer generates old dtags in addition to new dtags.
  * Remove linker support for MIPS ECOFF targets.
  * Add ALIGN_WITH_INPUT to the linker script language to force the alignment of
    an output section to use the maximum alignment of all its input sections.
2014-06-15 23:43:13 +00:00

15 lines
494 B
Text

$NetBSD: patch-ai,v 1.1 2014/06/15 23:43:14 mef Exp $
Avoid installing po (nls) files
--- gas/Makefile.in.orig 2011-06-14 00:18:47.000000000 +0900
+++ gas/Makefile.in 2012-02-06 21:51:43.000000000 +0900
@@ -281,7 +281,7 @@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = 1.11 dejagnu foreign no-dist
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
-SUBDIRS = doc po
+SUBDIRS = doc
tooldir = $(exec_prefix)/$(target_alias)
# Automake 1.10+ disables lex and yacc output file regeneration if