pkgsrc/cross/nios2-binutils/patches/patch-aj
mef 14bb9862e2 (pkgsrc)
Switch from Codesourcery to GNU FSF
(Upstream 2.23.2 to 2.24.0)
- binutils
  * Objcopy now supports wildcard characters in command line options that take
    section names.
  * Add support for Altera Nios II.
- gas
  * Add support for the Texas Instruments MSP430X processor.
  * Add -gdwarf-sections command line option to enable per-code-section
    generation of DWARF .debug_line sections.
  * Add support for Altera Nios II.
  * Add support for the Imagination Technologies Meta processor.
  * Add support for the v850e3v5.
  * Remove assembler support for MIPS ECOFF targets.
- ld
  * Add LOG2CEIL() builtin function to the linker script language
  * Add support for the Texas Instruments MSP430X processor.
  * Add support for Altera Nios II.
  * Add support for the V850E3V5 architecture.
  * Add support for the Imagination Technologies Meta processor.
  * --enable-new-dtags no longer generates old dtags in addition to new dtags.
  * Remove linker support for MIPS ECOFF targets.
  * Add ALIGN_WITH_INPUT to the linker script language to force the alignment of
    an output section to use the maximum alignment of all its input sections.
2014-06-15 23:43:13 +00:00

24 lines
768 B
Text

$NetBSD: patch-aj,v 1.1 2014/06/15 23:43:14 mef Exp $
Avoid installing info and po (nls) files
--- gprof/Makefile.in.orig 2012-06-02 19:19:23.000000000 +0900
+++ gprof/Makefile.in 2013-01-27 07:21:40.000000000 +0900
@@ -93,7 +93,7 @@ LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLF
--mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
SOURCES = $(gprof_SOURCES)
-INFO_DEPS = gprof.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
DVIS = gprof.dvi
PDFS = gprof.pdf
@@ -279,7 +279,7 @@ AUTOMAKE_OPTIONS = 1.11 foreign no-dist
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
TEXINFO_TEX = ../texinfo/texinfo.tex
SUFFIXES = .m
-SUBDIRS = po
+SUBDIRS =
BASEDIR = $(srcdir)/..
BFDDIR = $(BASEDIR)/bfd
INCDIR = $(BASEDIR)/include