pkgsrc/wm/enlightenment/patches/patch-aa
jlam 63fc151cb9 Use x11.buildlink.mk instead of USE_X11. Also convert hard-coded references
to ${X11BASE} in the header and library search paths into references to
${LOCALBASE}/share/x11-links.  These packages should now be strongly-
buildlinked regardless of whether xpkgwedge is installed.

Changes well-tested on NetBSD-1.5X/i386 with and without xpkgwedge and
lightly-tested on NetBSD-1.5.1/alpha without xpkgwedge.
2001-08-29 22:41:00 +00:00

306 lines
11 KiB
Text

$NetBSD: patch-aa,v 1.2 2001/08/29 22:41:23 jlam Exp $
--- configure.orig Mon Apr 10 19:19:49 2000
+++ configure
@@ -4810,7 +4810,7 @@
if test "x$enable_fsstd" = "xyes"; then
ENLIGHTENMENT_ROOT=${datadir}/enlightenment
ENLIGHTENMENT_BIN=${bindir}
- LOCALEDIR=${prefix}/${DATADIRNAME}/locale
+ LOCALEDIR=${prefix}/share/locale
USE_FSSTD=yes
else
ENLIGHTENMENT_ROOT=${prefix}/enlightenment
@@ -5317,7 +5317,6 @@
rm -f conf.imlibtest
-LDFLAGS="$LDFLAGS -L$prefix/lib"
LDFLAGS="$LDFLAGS `echo $IMLIB_LIBS | sed 's/\(.*\)-lImlib.*/\1/'`"
LDFLAGS="$LDFLAGS `echo $IMLIB_LIBS | sed 's/.*-lImlib.*\(-L[^ ]*\).*$/\1/'`"
XTST_LIBS=""
@@ -5473,7 +5472,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lttf -lm $LIBS"
+LIBS="-lttf -lintl -lm $LIBS"
cat > conftest.$ac_ext <<EOF
#line 5479 "configure"
#include "confdefs.h"
@@ -5501,7 +5500,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- TTF_LIBS=-lttf
+ TTF_LIBS="-lttf -lintl"
else
echo "$ac_t""no" 1>&6
@@ -5518,14 +5517,14 @@
-echo $ac_n "checking for dlopen in -ldl""... $ac_c" 1>&6
-echo "configure:5523: checking for dlopen in -ldl" >&5
-ac_lib_var=`echo dl'_'dlopen | sed 'y%./+-%__p_%'`
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+
+echo $ac_n "checking for library containing dlopen""... $ac_c" 1>&6
+echo "configure:5524: checking for library containing dlopen" >&5
+if eval "test \"`echo '$''{'ac_cv_search_dlopen'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
- ac_save_LIBS="$LIBS"
-LIBS="-ldl -lm $LIBS"
+ ac_func_search_save_LIBS="$LIBS"
+ac_cv_search_dlopen="no"
cat > conftest.$ac_ext <<EOF
#line 5531 "configure"
#include "confdefs.h"
@@ -5540,23 +5539,45 @@
EOF
if { (eval echo configure:5542: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=yes"
+ ac_cv_search_dlopen="none required"
else
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=no"
fi
rm -f conftest*
-LIBS="$ac_save_LIBS"
+test "$ac_cv_search_dlopen" = "no" && for i in "dl"; do
+LIBS="-l$i -lm $ac_func_search_save_LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 5553 "configure"
+#include "confdefs.h"
+/* Override any gcc2 internal prototype to avoid an error. */
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char dlopen();
-fi
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- DL_LIBS=-ldl
+int main() {
+dlopen()
+; return 0; }
+EOF
+if { (eval echo configure:5564: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ ac_cv_search_dlopen="-l$i"
+break
else
- echo "$ac_t""no" 1>&6
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+done
+LIBS="$ac_func_search_save_LIBS"
+fi
+echo "$ac_t""$ac_cv_search_dlopen" 1>&6
+if test "$ac_cv_search_dlopen" != "no"; then
+ test "$ac_cv_search_dlopen" = "none required" || LIBS="$ac_cv_search_dlopen $LIBS"
+ DL_LIBS=$LIBS
+else :
+
echo "Warning: Enlightenment requires the dl (dynamic loader) library"
echo "to be supported on your platform for module support. Modules"
echo "have been disabled (this will affect functionality)"
@@ -5564,9 +5585,8 @@
fi
-
echo $ac_n "checking for XTestGrabControl in -lXtst""... $ac_c" 1>&6
-echo "configure:5570: checking for XTestGrabControl in -lXtst" >&5
+echo "configure:5591: checking for XTestGrabControl in -lXtst" >&5
ac_lib_var=`echo Xtst'_'XTestGrabControl | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5574,7 +5594,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lXtst $X_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5578 "configure"
+#line 5599 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5585,7 +5605,7 @@
XTestGrabControl()
; return 0; }
EOF
-if { (eval echo configure:5589: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5610: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5613,7 +5633,7 @@
fi
echo $ac_n "checking for XTestQueryExtension in -lXtst""... $ac_c" 1>&6
-echo "configure:5617: checking for XTestQueryExtension in -lXtst" >&5
+echo "configure:5638: checking for XTestQueryExtension in -lXtst" >&5
ac_lib_var=`echo Xtst'_'XTestQueryExtension | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5621,7 +5641,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lXtst $X_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5625 "configure"
+#line 5646 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5632,7 +5652,7 @@
XTestQueryExtension()
; return 0; }
EOF
-if { (eval echo configure:5636: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5657: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5654,7 +5674,7 @@
echo $ac_n "checking for XkbQueryExtension in -lXext""... $ac_c" 1>&6
-echo "configure:5658: checking for XkbQueryExtension in -lXext" >&5
+echo "configure:5679: checking for XkbQueryExtension in -lXext" >&5
ac_lib_var=`echo Xext'_'XkbQueryExtension | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5662,7 +5682,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lXext $X_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5666 "configure"
+#line 5687 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5673,7 +5693,7 @@
XkbQueryExtension()
; return 0; }
EOF
-if { (eval echo configure:5677: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5698: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5697,7 +5717,7 @@
fi
echo $ac_n "checking for XineramaQueryExtension in -lXinerama""... $ac_c" 1>&6
-echo "configure:5701: checking for XineramaQueryExtension in -lXinerama" >&5
+echo "configure:5722: checking for XineramaQueryExtension in -lXinerama" >&5
ac_lib_var=`echo Xinerama'_'XineramaQueryExtension | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5705,7 +5725,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lXinerama $X_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5709 "configure"
+#line 5730 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5716,7 +5736,7 @@
XineramaQueryExtension()
; return 0; }
EOF
-if { (eval echo configure:5720: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5741: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5753,7 +5773,7 @@
if test "x$enable_zoom" = "xyes"; then
echo $ac_n "checking for XF86VidModeQueryExtension in -lXxf86vm""... $ac_c" 1>&6
-echo "configure:5757: checking for XF86VidModeQueryExtension in -lXxf86vm" >&5
+echo "configure:5778: checking for XF86VidModeQueryExtension in -lXxf86vm" >&5
ac_lib_var=`echo Xxf86vm'_'XF86VidModeQueryExtension | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5761,7 +5781,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lXxf86vm $X_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5765 "configure"
+#line 5786 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5772,7 +5792,7 @@
XF86VidModeQueryExtension()
; return 0; }
EOF
-if { (eval echo configure:5776: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5797: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5808,7 +5828,7 @@
echo $ac_n "checking for mass_quantities_of_bass_ale in -lFridge""... $ac_c" 1>&6
-echo "configure:5812: checking for mass_quantities_of_bass_ale in -lFridge" >&5
+echo "configure:5833: checking for mass_quantities_of_bass_ale in -lFridge" >&5
ac_lib_var=`echo Fridge'_'mass_quantities_of_bass_ale | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5816,7 +5836,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lFridge $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5820 "configure"
+#line 5841 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5827,7 +5847,7 @@
mass_quantities_of_bass_ale()
; return 0; }
EOF
-if { (eval echo configure:5831: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5852: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -5855,7 +5875,7 @@
fi
echo $ac_n "checking for mass_quantities_of_any_ale in -lFridge""... $ac_c" 1>&6
-echo "configure:5859: checking for mass_quantities_of_any_ale in -lFridge" >&5
+echo "configure:5880: checking for mass_quantities_of_any_ale in -lFridge" >&5
ac_lib_var=`echo Fridge'_'mass_quantities_of_any_ale | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -5863,7 +5883,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lFridge $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 5867 "configure"
+#line 5888 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -5874,7 +5894,7 @@
mass_quantities_of_any_ale()
; return 0; }
EOF
-if { (eval echo configure:5878: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:5899: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else