While here, remove restriction, it's "please", not "have to". see: http://packages.debian.org/changelogs/pool/main/p/pstoedit/pstoedit_3.45-8/pstoedit.copyright New or changed in 3.50: * added an option (-gs) to specify the full path to GhostScript (under Windows - either the .exe or the DLL). This can be used by portable applications to direct pstoedit to use a specific GhostScript version. * Stanislav Brabec contributed several improvements to the PCB driver. See http://www.penguin.cz/~utx/pstoedit-pcb/ on how these can be useful. * Scott Pakin submitted several improvements to the mpost driver and the font substitution mechanism. * new driver for .vtk files e.g. for ParaView - http://www.paraview.org/ - but this is still a very basic version. Thanks to Mitesh Patel for initiating and testing. * new driver for cairo (http://cairographics.org/ ) contributed by Dan McMahill. This driver generates C-code which can be compiled and linked against the cairo libraries. See the contrib/cairo directory for an example. * several improvements on the DXF driver as suggested and sponsored by Markus Meyer. * because pstoedit may write its output to stdout, all output written by GhostScript to stdout is now redirected to stderr in order to avoid mixed output. * added a -q option to suppress the initial startup message of pstoedit. This can by useful when being called via a pipe, e.g. from inkscape. However, note that this does not suppress all output written to stderr - see also note above. * John Bowman fixed a number of problems related to clipping and image support for the Asymptote backend. * fixed a compilation problem with g++ V4.x. * new driver for gcode (.ngc files) (tested with emc see http://linuxcnc.org). Contributed by Lawrence Glaister. * some adaptations for newer versions of libming * fixed a line width problem for xfig format. * corrected the broken pstoedit.m4 - thanks to Ian Abbott * some minor code beautifying.
13 lines
495 B
Text
13 lines
495 B
Text
$NetBSD: patch-ab,v 1.6 2010/04/13 06:53:20 obache Exp $
|
|
|
|
--- src/Makefile.in.orig 2009-08-13 08:18:34.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -396,7 +396,7 @@ libpstoedit_la_SOURCES = \
|
|
genericints.h \
|
|
version.h
|
|
|
|
-libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} -ldl -lm
|
|
+libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} -lm
|
|
libpstoedit_la_LDFLAGS = -no-undefined
|
|
pstoedit_SOURCES = cmdmain.cpp
|
|
pstoedit_LDFLAGS = -no-undefined -L. libpstoedit.la ${LIBLD_LDFLAGS}
|