911ad3256b
- use ${MACHINE_GNU_PLATFORM} in place of ${MACHINE_GNU_ARCH}--netbsd - check for -lossaudio in ./configure instead of linking with it unconditionally - fixe Makefiles for bmake or gmake on solaris2 While I'm there merge back a change from configure to configure.in
44 lines
1.5 KiB
Text
44 lines
1.5 KiB
Text
$NetBSD: patch-af,v 1.3 1999/12/06 14:24:02 bouyer Exp $
|
|
|
|
--- configure.in.orig Sun Aug 15 03:29:49 1999
|
|
+++ configure.in Mon Dec 6 11:20:27 1999
|
|
@@ -1027,6 +1027,7 @@
|
|
|
|
dnl Straightforward machine determination
|
|
case "$canonical" in
|
|
+ arm-*-* ) machine=arm ;;
|
|
sparc-*-* ) machine=sparc ;;
|
|
alpha*-*-* ) machine=alpha ;;
|
|
vax-*-* ) machine=vax ;;
|
|
@@ -1101,10 +1102,10 @@
|
|
case "$canonical" in
|
|
i[[3-9]]86-*-netbsd*) machine=intel386 ;;
|
|
hp300-*-netbsd* | amiga-*-netbsd* | sun3-*-netbsd* | mac68k-*-netbsd* | da30-*-netbsd* | m68k-*-netbsd* )
|
|
- dnl Yes, this is somewhat bogus.
|
|
- machine=hp9000s300 ;;
|
|
+ machine=m68k ;;
|
|
pc532-*-netbsd* | ns32k-*-netbsd* ) machine=ns32000 ;;
|
|
pmax-*-netbsd* | mips-*-netbsd* ) machine=pmax ;;
|
|
+ alpha-*-netbsd* ) machine=alpha ;;
|
|
esac
|
|
;;
|
|
|
|
@@ -1941,7 +1942,7 @@
|
|
decosf* | linux* | irix*) dash_r="-rpath " ;;
|
|
*)
|
|
dash_r=""
|
|
- for try_dash_r in "-R" "-R " "-rpath "; do
|
|
+ for try_dash_r in "-Wl,-R" "-R" "-R " "-rpath "; do
|
|
xe_check_libs="${try_dash_r}/no/such/file-or-directory"
|
|
XE_PROTECT_LINKER_FLAGS(xe_check_libs)
|
|
AC_TRY_LINK(, , dash_r="$try_dash_r")
|
|
@@ -3485,6 +3486,9 @@
|
|
eval "with_${feature}=no"
|
|
done
|
|
fi dnl with_tty
|
|
+
|
|
+AC_CHECK_LIB(ossaudio, main, LIBOSSAUDIO=-lossaudio)
|
|
+AC_SUBST(LIBOSSAUDIO)
|
|
|
|
dnl Do we need event-unixoid.o ?
|
|
test "$with_x11" = "yes" -o "$with_tty" = "yes" && XE_ADD_OBJS(event-unixoid.o)
|