7bcb80ebad
including much improved viewers and inspectors, improved iconisation, and many bug fixes. While at it, replace home grown PLIST substitution with standard GNUstep buildlink2.mk symbols.
31 lines
695 B
Text
31 lines
695 B
Text
$NetBSD: patch-aa,v 1.1 2003/07/06 08:51:34 rh Exp $
|
|
|
|
--- Utilities/thumbnailer/main.m.orig 2003-06-30 23:40:26.000000000 +1000
|
|
+++ Utilities/thumbnailer/main.m
|
|
@@ -677,18 +677,26 @@ int main(int argc, char** argv, char **e
|
|
exit(0);
|
|
}
|
|
|
|
+#if GS_WITH_GC
|
|
CREATE_AUTORELEASE_POOL (pool);
|
|
+#endif
|
|
thumbnailer = [Thumbnailer new];
|
|
+#if GS_WITH_GC
|
|
RELEASE (pool);
|
|
+#endif
|
|
|
|
if (thumbnailer != nil) {
|
|
+#if GS_WITH_GC
|
|
CREATE_AUTORELEASE_POOL (pool);
|
|
+#endif
|
|
|
|
[NSApplication sharedApplication];
|
|
NSRegisterServicesProvider(thumbnailer, @"Thumbnailer");
|
|
[[NSRunLoop currentRunLoop] run];
|
|
|
|
+#if GS_WITH_GC
|
|
RELEASE (pool);
|
|
+#endif
|
|
}
|
|
|
|
exit(0);
|