pkgsrc/games/openhexagon/patches/patch-CMakeLists.txt
plunky f9378ab377 Added openhexagon-2.0-preview from pkgsrc-wip
"You are a triangle."

Fast paced, challenging, free to play, open source game.

You control a little triangle, which can be rotated clockwise or
counterclockwise. Your goal is to suvive as long as possible by
dodging polygons that move towards the center. Things get more
difficult as time passes!

Features a lot of variety and full customization: users can
create/modify/share levels, patterns, music, sounds, scripts,
and more.

Play in Official Mode and submit your highscores to the
server. Be the first in the leaderboards!

Clone of the game "Super Hexagon" by Terry Cavanagh.
Please check it out and consider buying it if you like Open Hexagon!
2020-05-21 08:42:57 +00:00

19 lines
938 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.1 2020/05/21 08:42:57 plunky Exp $
install in pkgsrc dirs
--- CMakeLists.txt.orig 2013-07-13 23:37:47.000000000 +0000
+++ CMakeLists.txt
@@ -65,10 +65,8 @@ target_link_libraries(${PROJECT_NAME} ${
target_link_libraries(${PROJECT_NAME} ${LUA_LIBRARY})
if(UNIX)
- install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION /usr/local/games/${PROJECT_NAME}/)
- install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION ${CMAKE_SOURCE_DIR}/_RELEASE/)
- install(DIRECTORY _RELEASE/ DESTINATION /usr/local/games/SSVOpenHexagon/)
- install(PROGRAMS _RELEASE/${PROJECT_NAME} DESTINATION /usr/local/games/${PROJECT_NAME}/ PERMISSIONS WORLD_EXECUTE WORLD_READ)
+ install(DIRECTORY _RELEASE/ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/${PKGBASE}/)
+ install(PROGRAMS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/${PKGBASE}/)
else(WIN32)
install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION ./_RELEASE/)
endif()