pkgsrc/graphics/kdegraphics3/patches/patch-ag
markd 9238478044 Update KDE to 3.1.
Many bugfixes and functionality enhancements including:

kdegraphics

 KView:
    Added KImageViewer interface
    Added possibility for plugins
    Added Slideshow plugin
    Enhanced Mousewheel support
    Automatic resizing to fit images with varying size
 kviewshell: added statusbar
 kviewshell: usability improvements
 KuickShow: Digital camera jpeg images obey orientaion information
 KuickShow: General UI improvements, now features a menubar
 KuickShow: Ability to browse image collections on remote servers
 KuickShow: Digital camera jpeg images obey orientaion information
 KPovModeler: Implement support for the missing PovRAY 3.1 primitives,
 zehender at kde org.
 KFax: Rewrite all the UI code to be KDE standards compliant, cleanups.
 (Nadeem Hasan <nhasan@kde.org>)
 libkscan: support for halftoning scan mode where available
 kooka: thumbnail view of scanned images added
 kooka: ported to KDockWidgets to provide a customizable GUI
 kooka: inline image renaming and drag and drop
 NEW IN KDE:KPovModeler, a modeling and composition program for creating
 POV-Ray (tm) scenes
2003-03-11 13:24:56 +00:00

47 lines
1.7 KiB
Text

$NetBSD: patch-ag,v 1.2 2003/03/11 13:25:00 markd Exp $
--- kuickshow/src/Makefile.am.orig Mon Sep 16 09:12:49 2002
+++ kuickshow/src/Makefile.am
@@ -1,25 +1,28 @@
## Makefile.am for kuickshow
bin_PROGRAMS = kuickshow
-lib_LTLIBRARIES = kuickshow.la
+lib_LTLIBRARIES = libkuickshow_main.la kuickshow.la
# set the include path for X, qt and KDE
INCLUDES = $(all_includes)
KDE_CXXFLAGS = $(IMLIB_CFLAGS)
-CLEANFILES = dummy.cpp
METASOURCES = AUTO
-kuickshow_la_LDFLAGS = $(all_libraries) -module -avoid-version
-kuickshow_la_LIBADD = $(LIB_KDEPRINT) $(LIB_IMLIB)
-kuickshow_la_SOURCES = kuickshow.cpp \
+libkuickshow_main_la_LDFLAGS = $(all_libraries)
+libkuickshow_main_la_LIBADD = $(LIB_KDEPRINT) $(LIB_IMLIB)
+libkuickshow_main_la_SOURCES = kuickshow.cpp \
aboutwidget.cpp generalwidget.cpp kuickconfigdlg.cpp main.cpp \
defaultswidget.cpp imagewindow.cpp kuickdata.cpp \
imdata.cpp filefinder.cpp kurlwidget.cpp filewidget.cpp \
kuickio.cpp kuick.cpp imlibwidget.cpp slideshowwidget.cpp printing.cpp
+kuickshow_la_LDFLAGS = $(all_libraries) -module -avoid-version
+kuickshow_la_LIBADD = $(LIB_KDEPRINT) $(LIB_IMLIB) libkuickshow_main.la
+kuickshow_la_SOURCES = kuickshow_main.cpp
+
# now the kuickshow binary
-kuickshow_LDADD = kuickshow.la $(LIB_KIO) $(LIB_IMLIB)
-kuickshow_SOURCES = dummy.cpp
+kuickshow_LDADD = libkuickshow_main.la $(LIB_KIO) $(LIB_IMLIB)
+kuickshow_SOURCES = kuickshow_main.cpp
kuickshow_LDFLAGS = $(all_libraries) $(KDE_RPATH)
@@ -35,6 +38,3 @@ KDE_ICON = kuickshow
# this is where the kdelnk file will go
appsdir = $(kde_appsdir)/Graphics
apps_DATA = kuickshow.desktop
-
-dummy.cpp:
- echo "// generated dummy file" > dummy.cpp