pkgsrc/security/opendnssec/patches/patch-enforcer_utils_Makefile.am
he a7c1be6a61 Update OpenDNSSEC from version 1.3.14nb1 to 1.4.1.
Pkgsrc changes:
 * Get rid of ruby dependencies, since the validator is no longer
   included in OpenDNSSEC
 * Adapt PLIST to changes in installed files
 * Add a patch so that the database migration scripts are installed
   as part of the package

Upstream notable changes:
 *  SUPPORT-58: Extend ods-signer sign <zone> with -serial <nr> so
    that the user can specify the SOA serial to use in the signed
    zone [OPENDNSSEC-401].
 *  OPENDNSSEC-91: Make the keytype flag required when rolling keys

Bugfixes:
 *  SUPPORT-60: Fix datecounter in case inbound serial is higher
    than outbound serial [OPENDNSSEC-420].
 *  OPENDNSSEC-247: Signer Engine: TTL on NSEC3 was not updated on
    SOA Minimum change.
 *  OPENDNSSEC-421: Signer Engine: Fix assertion error in case
    NSEC3 hash algorithm in signconf is not SHA1.
 *  OPENDNSSEC-421: ods-kaspcheck: Check whether NSEC3 hash algorithm
    in kasp is valid.
 *  Bugfix: The time when inbound serial is acquired was reset
    invalidly, could cause OpenDNSSEC wanting AXFR responses while
    requesting IXFR (thanks Stuart Lau).
 *  Bugfix: Fix malform in Outbound IXFR/TCP subsequent packet
    (thanks Stuart Lau).
 *  OPENDNSSEC-398: The ods-ksmutil key rollover command does not
    work correctly when rolling all keys using the -policy option
2013-08-22 11:05:45 +00:00

16 lines
562 B
Text

$NetBSD: patch-enforcer_utils_Makefile.am,v 1.1 2013/08/22 11:05:45 he Exp $
Install the conversion scripts.
--- enforcer/utils/Makefile.am.orig 2012-10-24 10:42:52.000000000 +0000
+++ enforcer/utils/Makefile.am
@@ -43,3 +43,9 @@ EXTRA_DIST = $(srcdir)/migrate_*.pl
EXTRA_DIST += $(srcdir)/migrate_adapters_1.*
EXTRA_DIST += $(srcdir)/convert_database.pl
EXTRA_DIST += $(srcdir)/migrate_zone_delete.mysql
+
+install-data-local: $(EXTRA_DIST)
+ for f in $(EXTRA_DIST); do \
+ $(INSTALL_DATA) "$$f" $(DESTDIR)$(opendnssecdatadir) \
+ || exit $$?; \
+ done