- Updating package for file from 5.00 to 5.03 - Adding/updating patch which prevents non-gcc is invoked with gcc's warning options Upstream changes: 2009-05-06 10:25 Christos Zoulas <christos@zoulas.com> * Avoid null dereference in cdf code (Drew Yao) * More cdf bounds checks and overflow checks 2009-05-01 18:37 Christos Zoulas <christos@zoulas.com> * Buffer overflow fixes from Drew Yao 2009-04-30 17:10 Christos Zoulas <christos@zoulas.com> * Fix more cdf lossage. All the documents I have right now print the correct information. 2009-03-27 18:43 Christos Zoulas <christos@zoulas.com> * don't print \012- separators in the same magic entry if it consists of multiple magic printing lines. 2009-03-23 10:20 Christos Zoulas <christos@zoulas.com> * Avoid file descriptor leak in compress code from (Daniel Novotny) 2009-03-18 16:50 Christos Zoulas <christos@zoulas.com> * Allow escaping of relation characters, so that we can say \^[A-Z] and the ^ is not eaten as a relation char. * Fix troff and fortran to their previous glory using regex. This was broken since their removel from ascmagic. 2009-03-10 16:50 Christos Zoulas <christos@zoulas.com> * don't use strlen in strndup() (Toby Peterson) 2009-03-10 7:45 Christos Zoulas <christos@zoulas.com> * avoid c99 syntax. 2009-02-23 15:45 Christos Zoulas <christos@zoulas.com> * make the cdf code use the buffer first if available, and then the fd code.
27 lines
883 B
Text
27 lines
883 B
Text
$NetBSD: patch-ac,v 1.1 2009/05/21 15:58:18 sno Exp $
|
|
|
|
If $gcc is unset, original comparisation fails badly
|
|
regardless 'if test = no' or 'if test "" = no'
|
|
|
|
--- configure.ac.orig 2009-05-18 17:20:17.000000000 +0000
|
|
+++ configure.ac 2009-05-18 17:22:15.000000000 +0000
|
|
@@ -130,15 +130,15 @@
|
|
-Wsign-compare -Wreturn-type -Wswitch -Wshadow \
|
|
-Wcast-qual -Wwrite-strings -Wextra -Wunused-parameter"
|
|
fi], [
|
|
-if test "$GCC" = no; then
|
|
- WARNINGS=
|
|
- AC_MSG_RESULT(no)
|
|
-else
|
|
+if test "$GCC" = yes; then
|
|
AC_MSG_RESULT(yes)
|
|
WARNINGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith \
|
|
-Wmissing-declarations -Wredundant-decls -Wnested-externs \
|
|
-Wsign-compare -Wreturn-type -Wswitch -Wshadow \
|
|
-Wcast-qual -Wwrite-strings -Wextra -Wunused-parameter"
|
|
+else
|
|
+ WARNINGS=
|
|
+ AC_MSG_RESULT(no)
|
|
fi])
|
|
|
|
dnl Checks for functions
|