pkgsrc/misc/libreoffice/patches/patch-configure.ac
ryoon 30806f3279 libreoffice: Update to 6.4.0.3
* Do not use PDFium's internal freetype2.
  Not tested with X11_TYPE=native yet.
* GTK2 VCL is removed.

Changelog:
# Writer
Added option to mark comments as resolved.
Fix missing change tracking layout of numbers and bullets of lists.
The btLr text direction is now available.
It is now possible to comment on Writer images and charts.
It is now possible to automatically avoid overlapping shapes with a new wrap option.
Improved performance when importing files with many bookmarks.
Selection of drawing objects anchored at-paragraph works more consistently and user-friendly now.

## Tables
Important improvements in table handling.
Improved drag & drop mouse operations to move table data.

# Calc
Improved selecting cells which contain hyperlinks.
n MM:SS or [MM]:SS or MM:SS.00 or [MM]:SS.00 pre-formatted cells a two digit groups input like 12:34 is now accepted as minutes:seconds value instead of the usual hours:minutes:00 value; to force the usual hours:minutes:seconds input on such cells enter three digit groups like 12:34:00.
Improved scalability of formula-groups computation on CPUs with large number of cores by potentially threading multiple independent formula-groups together.
Implemented a parallelized version of super scalar sample sort algorithm to speed up sorting. This is now used in pivot-table creation where some sorting is required.
Shading of columns/rows headers is removed; the headers are drawn flat now.
Deleted a 15 symbols limit to password length for XLSX files.
Performance improvements.
Full-Sheet Previews.

# Impress & Draw
Added 'Remove Hyperlink' to context menu in Impress.
Added 'Consolidate Text' which combines multiple selected textboxes into one (primarily to simplify editing fragmented content from imported PDFs).
Interaction now only executed in presentation mode (when clicking on an object). For edit mode, a context menu "Execute interaction" was added.
Image Maps now respect the setting to require Ctrl+Click to follow the hyperlink.
Hyperlink in Image Maps now work in Slideshow too.
Performance improvements.

# Base
Access2Base callable from Python.

# BASIC
Fix hex number conversion.
Improvements in VBA handling.
Fix handling for function that does not has closing parenthesis.

# Core / General
Internal Paths are now displayed in the UI.
Add checkbox to enable/disable sending crash reports to TDF.
Hyperlink context menus were unified. Every hyperlink now has the following context menu entries.
Generate QR Code feature is added in LO.
2020-02-05 14:10:35 +00:00

102 lines
4.6 KiB
Text

$NetBSD: patch-configure.ac,v 1.15 2020/02/05 14:10:35 ryoon Exp $
* Add NetBSD/aarch64 support.
* Disable freetype2 and fontconfig from pkgsrc explicitly.
to fix X11_TYPE=native build and internal pdfium's internal freetype build.
* Exclude c++2a to avoid some C++ errors. And c++17 causes alloca(3) problem.
Use gnu++17 dialect instead.
* Fix some static links.
* Include header files from gpgme correctly.
* Find pkgsrc/devel/apache-ant.
--- configure.ac.orig 2020-01-22 23:14:16.000000000 +0000
+++ configure.ac
@@ -4526,6 +4526,11 @@ linux-android*)
RTL_ARCH=X86_64
PLATFORMID=netbsd_x86_64
;;
+ aarch64)
+ CPUNAME=AARCH64
+ RTL_ARCH=AARCH64
+ PLATFORMID=netbsd_aarch64
+ ;;
*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
;;
@@ -4923,6 +4928,7 @@ fi
AC_SUBST(ENABLE_CUPS)
# fontconfig checks
+#test_fontconfig=no
if test "$test_fontconfig" = "yes"; then
PKG_CHECK_MODULES([FONTCONFIG], [fontconfig >= 2.4.1])
SYSTEM_FONTCONFIG=TRUE
@@ -6446,7 +6452,7 @@ CXXFLAGS_CXX11=
if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
CXXFLAGS_CXX11='-std:c++17 -Zc:__cplusplus'
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
- my_flags='-std=c++2a -std=c++17 -std=c++1z'
+ my_flags='-std=gnu++17 -std=gnu++1z'
for flag in $my_flags; do
if test "$COM" = MSC; then
flag="-Xclang $flag"
@@ -8097,7 +8103,7 @@ else
if test "$COM" = "MSC"; then
LIBJPEG_LIBS="${WORKDIR}/UnpackedTarball/libjpeg-turbo/.libs/libjpeg.lib"
else
- LIBJPEG_LIBS="-L${WORKDIR}/UnpackedTarball/libjpeg-turbo/.libs -ljpeg"
+ LIBJPEG_LIBS="${WORKDIR}/UnpackedTarball/libjpeg-turbo/.libs/libjpeg.a"
fi
case "$host_cpu" in
@@ -8409,6 +8415,7 @@ fi
dnl ===================================================================
dnl Check whether freetype is available
dnl ===================================================================
+#test_freetype=no
if test "$test_freetype" = "yes"; then
AC_MSG_CHECKING([whether freetype is available])
# FreeType has 3 different kinds of versions
@@ -8425,7 +8432,7 @@ if test "$test_freetype" = "yes"; then
SYSTEM_FREETYPE=TRUE
else
FREETYPE_CFLAGS="${ISYSTEM}${WORKDIR}/UnpackedTarball/freetype/include"
- FREETYPE_LIBS="-L${WORKDIR}/UnpackedTarball/freetype/instdir/lib -lfreetype"
+ FREETYPE_LIBS="${WORKDIR}/UnpackedTarball/freetype/instdir/lib/libfreetype.a"
fi
AC_SUBST(FREETYPE_CFLAGS)
AC_SUBST(FREETYPE_LIBS)
@@ -9685,11 +9692,11 @@ dnl HarfBuzz
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3],
["-I${WORKDIR}/UnpackedTarball/graphite/include -DGRAPHITE2_STATIC"],
- ["-L${WORKDIR}/LinkTarget/StaticLibrary -lgraphite"])
+ ["${WORKDIR}/LinkTarget/StaticLibrary/libgraphite.a"])
libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.42],
["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],
- ["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
+ ["${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs/libharfbuzz.a"])
if test "$COM" = "MSC"; then # override the above
GRAPHITE_LIBS="${WORKDIR}/LinkTarget/StaticLibrary/graphite.lib"
@@ -10898,7 +10905,7 @@ elif test "$_os" = "Linux" -o "$_os" = "
SYSTEM_GPGMEPP=TRUE
# C++ library doesn't come with fancy gpgmepp-config, check for headers the old-fashioned way
- AC_CHECK_HEADER(gpgme++/gpgmepp_version.h, [ GPGMEPP_CFLAGS=-I/usr/include/gpgme++ ],
+ AC_CHECK_HEADER(gpgme++/gpgmepp_version.h, [ GPGMEPP_CFLAGS=-I/usr/pkg/include/gpgme++ ],
[AC_MSG_ERROR([gpgmepp headers not found, install gpgmepp development package])], [])
# progress_callback is the only func with plain C linkage
# checking for it also filters out older, KDE-dependent libgpgmepp versions
@@ -11965,8 +11972,8 @@ EOF
if test -f /usr/share/ant-core/lib/ant.jar; then
ANT_LIB=/usr/share/ant-core/lib
else
- if test -f $ANT_HOME/lib/ant/ant.jar; then
- ANT_LIB="$ANT_HOME/lib/ant"
+ if test -f $ANT_HOME/lib/java/ant/ant.jar; then
+ ANT_LIB="$ANT_HOME/lib/java/ant"
else
if test -f /usr/share/lib/ant/ant.jar; then
ANT_LIB=/usr/share/lib/ant