pkgsrc/net/gopher/patches/patch-ab
leot 27384a8851 gopher: Update to 3.0.17
Changes:
(changelog from debian/changelog with Debian-specific entries omitted)
3.0.17
------
  * Fix alignment issue in gopher directories.  Closes: #789892.

3.0.16
------
  * Bump compat to 9.  Closes: #817485.

3.0.15
------
  * Correct possible segfault in option parsing.  Closes #715977, #715978.

3.0.14
------
  * Fix Debian (Closes: #798758) thanks to patch from Axel Beckert
    + Use autoconf and gnulib instead of autoconf2.13.

3.0.13
------
  * More changes to download.c to prefer getcwd() to get_current_dir_name().
    Closes: #366560.

3.0.12
------
  * Applied patch to make it build for Hurd.  Closes: #346447.
2019-10-04 09:34:41 +00:00

25 lines
932 B
Text

$NetBSD: patch-ab,v 1.3 2019/10/04 09:34:41 leot Exp $
--- gopher/Makefile.in.orig 2005-07-20 17:28:52.000000000 +0200
+++ gopher/Makefile.in 2005-08-05 14:01:36.000000000 +0200
@@ -152,14 +152,12 @@
$(CC) $(LDFLAGS) -o $@ $(OBJS) ../object/libgopher.a @CLIENTLIBS@ @REGEXLIBS@ @LIBS@
install : all
- -mv $(CLIENTDIR)/$(TARGET) $(CLIENTDIR)/$(TARGET).old
- -mkdir $(CLIENTDIR)
- -mkdir $(CLIENTLIB)
- @INSTALL@ $(TARGET) $(CLIENTDIR)
- @INSTALL@ -d $(CLIENTLIB)
- @INSTALL@ gopher.rc $(CLIENTLIB)
- @INSTALL@ gopherremote.rc $(CLIENTLIB)
- @INSTALL@ gopher.hlp $(CLIENTLIB)
+ $(BSD_INSTALL_PROGRAM_DIR) $(CLIENTDIR)
+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(CLIENTDIR)/
+ $(BSD_INSTALL_DATA_DIR) ${DESTDIR}$(EGDIR)/
+ $(BSD_INSTALL_DATA) gopher.rc ${DESTDIR}$(EGDIR)/
+ $(BSD_INSTALL_DATA) gopherremote.rc ${DESTDIR}$(EGDIR)/
+ $(BSD_INSTALL_DATA) gopher.hlp ${DESTDIR}$(EGDIR)/
clean:
-rm -f $(TARGET) $(OBJS) *.out *~ core