Xen is a hypervisor which supports running multiple guest operating systems on a single machine. Guest OSes (also called "domains") can be either paravirtualised (i.e. make hypercalls in order to access hardware), run in HVM (Hardware Virtualisation Mode) where they will be presented with virtual devices, or a combination where they use hypercalls to access hardware but manage memory themselves. At boot, the xen kernel is loaded along with the guest kernel for the first domain (called domain0). domain0 has privileges to access the physical hardware (PCI and ISA devices), administrate other domains and provide virtual devices (disks and network) to other domains.
46 lines
1.5 KiB
Text
46 lines
1.5 KiB
Text
$NetBSD: patch-tools_hotplug_NetBSD_Makefile,v 1.1 2021/04/18 12:31:26 bouyer Exp $
|
|
|
|
--- tools/hotplug/NetBSD/Makefile.orig 2021-02-03 15:23:25.000000000 +0100
|
|
+++ tools/hotplug/NetBSD/Makefile 2021-02-03 15:28:32.949717159 +0100
|
|
@@ -10,7 +10,7 @@
|
|
XEN_SCRIPTS += qemu-ifup
|
|
|
|
XEN_SCRIPT_DATA =
|
|
-XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
|
|
+#XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
|
|
|
|
.PHONY: all
|
|
all:
|
|
@@ -26,10 +26,11 @@
|
|
|
|
.PHONY: install-scripts
|
|
install-scripts:
|
|
- $(INSTALL_DIR) $(DESTDIR)$(XEN_SCRIPT_DIR)
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts
|
|
set -e; for i in $(XEN_SCRIPTS); \
|
|
do \
|
|
- $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_SCRIPT_DIR); \
|
|
+ $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts; \
|
|
done
|
|
set -e; for i in $(XEN_SCRIPT_DATA); \
|
|
do \
|
|
@@ -43,12 +44,12 @@
|
|
|
|
.PHONY: install-rcd
|
|
install-rcd:
|
|
- $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
|
|
- set -e; for i in $(XEN_RCD_PROG); \
|
|
- do \
|
|
- $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
|
|
- done
|
|
- $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
|
|
+# $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
|
|
+# set -e; for i in $(XEN_RCD_PROG); \
|
|
+# do \
|
|
+# $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
|
|
+# done
|
|
+# $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
|
|
|
|
.PHONY: uninstall-rcd
|
|
uninstall-rcd:
|