pkgsrc/security/cyrus-sasl/patches/patch-aq
obache 1e0df3a9b8 Update cyrus-sasl (and plugins, authd) to 2.1.22.
New in 2.1.22
-------------

* Added support for spliting big data blocks (bigger than maxbuf)
  into multiple SASL packets in sasl_encodev
* Various sasl_decode64() fixes
* Increase canonicalization buffer size to 1024 bytes
* Call do_authorization() after successful APOP authentication
* Allow for configuration file location to be configurable independently
  of plugin location (bug # 2795)
* Added sasl_set_path function, which provides a more convenient way
  of setting plugin and config paths. Changed the default
  sasl_getpath_t/sasl_getconfpath_t callbacks to calculate
  the value only once and cache it for later use.
* Fixed load_config to search for the config file in all directories
  (bug # 2796). Changed the default search path to be
  /usr/lib/sasl2:/etc/sasl2
* Don't ignore log_level configuration option in default UNIX syslog
  logging callback
* (Windows) Minor IPv6 related changes in Makefiles for Visual Studio 6
* (Windows) Fixed bug of not setting the CODEGEN (code generation option)
  nmake option if STATIC nmake option is set.
* Several fixed to DIGEST-MD5 plugin:
  - Enable RC4 cipher in Windows build of DIGEST-MD5
  - Server side: handle missing realm option as if realm="" was sent
  - Fix DIGEST-MD5 to properly advertise maxssf when both DES and RC4
    are disabled
  - Check that DIGEST-MD5 SASL packet are no shorter than 16 bytes
* Several changes/fixed to SASLDB plugin:
  - Prevent spurious SASL_NOUSER errors
  - Added ability to keep BerkleyDB handle open between operations
    (for performance reason). New behavior can be enabled
    with --enable-keep-db-open.
* Better error checking in SQL (MySQL) auxprop plugin code
* Added support for HTTP POST password validation in saslauthd
* Added new application ("pluginviewer") that helps report information
  about installed plugins
* Allow for building with OpenSSL 0.9.8
* Allow for building with OpenLDAP 2.3+
* Several quoting fixes to configure script
* A large number of other minor bugfixes and cleanups
2006-10-04 12:07:53 +00:00

53 lines
1.9 KiB
Text

$NetBSD: patch-aq,v 1.5 2006/10/04 12:07:53 obache Exp $
--- sasldb/Makefile.in.orig 2006-05-18 15:30:16.000000000 -0400
+++ sasldb/Makefile.in
@@ -240,26 +240,18 @@ extra_common_sources = db_none.c db_ndbm
EXTRA_DIST = NTMakefile
noinst_LTLIBRARIES = libsasldb.la
-noinst_LIBRARIES = libsasldb.a
libsasldb_la_SOURCES = allockey.c sasldb.h
EXTRA_libsasldb_la_SOURCES = $(extra_common_sources)
libsasldb_la_DEPENDENCIES = $(SASL_DB_BACKEND)
libsasldb_la_LIBADD = $(SASL_DB_BACKEND)
-# Prevent make dist stupidity
-libsasldb_a_SOURCES =
-EXTRA_libsasldb_a_SOURCES =
subdir = sasldb
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
LIBRARIES = $(noinst_LIBRARIES)
-libsasldb_a_AR = $(AR) cru
-libsasldb_a_LIBADD =
-am_libsasldb_a_OBJECTS =
-libsasldb_a_OBJECTS = $(am_libsasldb_a_OBJECTS)
LTLIBRARIES = $(noinst_LTLIBRARIES)
libsasldb_la_LDFLAGS =
@@ -279,10 +271,9 @@ LTCOMPILE = $(LIBTOOL) --mode=compile $(
CCLD = $(CC)
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
-DIST_SOURCES = $(libsasldb_a_SOURCES) $(EXTRA_libsasldb_a_SOURCES) \
- $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
+DIST_SOURCES = $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
DIST_COMMON = Makefile.am Makefile.in
-SOURCES = $(libsasldb_a_SOURCES) $(EXTRA_libsasldb_a_SOURCES) $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
+SOURCES = $(libsasldb_la_SOURCES) $(EXTRA_libsasldb_la_SOURCES)
all: all-am
@@ -543,8 +534,6 @@ uninstall-am: uninstall-info-am
tags uninstall uninstall-am uninstall-info-am
-libsasldb.a: libsasldb.la $(SASL_DB_BACKEND_STATIC)
- $(AR) cru .libs/$@ $(SASL_DB_BACKEND_STATIC)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: