pkgsrc/databases/postgresql83/patches/patch-an
adam ccf532ab0c PostgreSQL 8.3
With significant new functionality and performance enhancements, this
release represents a major leap forward for PostgreSQL. This was made
possible by a growing community that has dramatically accelerated the
pace of development. This release adds the following major features:

  * Full text search is integrated into the core database system
  * Support for the SQL/XML standard, including new operators and an
    XML data type
  * Enumerated data types (ENUM)
  * Arrays of composite types
  * Universally Unique Identifier (UUID) data type
  * Add control over whether NULLs sort first or last
  * Updatable cursors
  * Server configuration parameters can now be set on a per-function
    basis
  * User-defined types can now have type modifiers
  * Automatically re-plan cached queries when table definitions change
    or statistics are updated
  * Numerous improvements in logging and statistics collection
  * Support Security Service Provider Interface (SSPI) for
    authentication on Windows
  * Support multiple concurrent autovacuum processes, and other
    autovacuum improvements
  * Allow the whole PostgreSQL distribution to be compiled with
    Microsoft Visual C++
2008-03-04 12:41:36 +00:00

13 lines
526 B
Text

$NetBSD: patch-an,v 1.1.1.1 2008/03/04 12:41:37 adam Exp $
--- src/interfaces/ecpg/test/Makefile.regress.orig 2007-01-21 10:19:06.000000000 +0100
+++ src/interfaces/ecpg/test/Makefile.regress
@@ -8,7 +8,7 @@ override LIBS := -lecpg -lpgtypes $(filt
ECPG = ../../preproc/ecpg --regression -I$(srcdir)/../../include
%: %.c
- $(CC) $(CPPFLAGS) $(CFLAGS) $^ $(LDFLAGS) $(LIBS) -o $@
+ ${LIBTOOL} --mode=link $(CC) $(CPPFLAGS) $(CFLAGS) $^ $(LDFLAGS) $(LIBS) -o $@
%.c: %.pgc ../regression.h
$(ECPG) -o $@ -I$(srcdir) $<