pkgsrc/print/scribus/patches/patch-ah
drochner cfb0264afa update to 1.3.3.13
changes:
-Several fixes and improvements to Pdf exporter
-More translation and documentation updates
-Several fixes to protect against possible crashes
-Improvements to the Scripter to enable more features

pkgsrc note: The gnu-autoconf based make system is completely broken
now, had to switch to cmake. Added cups dependency.
2009-09-16 09:24:55 +00:00

13 lines
397 B
Text

$NetBSD: patch-ah,v 1.4 2009/09/16 09:24:55 drochner Exp $
--- scribus/CMakeLists.txt.orig 2008-02-26 20:48:49.000000000 +0100
+++ scribus/CMakeLists.txt
@@ -431,6 +431,8 @@ ${SCRIBUS_TEXT_LIB}
${SCRIBUS_PIXBUF_LIB}
)
+SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS "-export-dynamic")
+
IF(RENDER_LIB STREQUAL "LIBART")
TARGET_LINK_LIBRARIES(${EXE_NAME}
${SCRIBUS_LIBART_LIB}