pkgsrc/mail/qpopper/patches/patch-am
taca f8fa0cefb8 Make qpopper build on Solaris.
- Remove extra rule line in install target.  (It tried to do make on
  password directory.)
- Solaris's /usr/ucb/install dosen't accept number with -g option.
2002-11-23 17:01:20 +00:00

38 lines
1.3 KiB
Text

$NetBSD: patch-am,v 1.2 2002/11/23 17:01:21 taca Exp $
--- popper/Makefile.in.orig Mon Apr 23 07:55:27 2001
+++ popper/Makefile.in Fri Nov 22 15:35:20 2002
@@ -87,6 +87,8 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
installdir = @sbindir@
+libexecdir = @libexecdir@
+sbindir = @sbindir@
popper_srcdir = ${top_srcdir}/popper
qd_srcdir = ${top_srcdir}/qd
@@ -199,17 +201,14 @@
${POPAUTHSRCS}:
install: popper ${pop_auth}
- ${INSTALL} -s -m 0755 -o root popper ${installdir}/popper
- echo "Installed popper as ${installdir}/popper"
- if [ "x${poppassd}" != "x" ]; then \
- cd ${password_dir} && ${MAKE} $@ ;\
- fi
- if [ "x${pop_auth}" != "x" ]; then \
- ${INSTALL} -s -m 4755 -o ${apop_uid} -g 0 ${pop_auth} \
- ${installdir}/${pop_auth}; \
- echo "Installed popauth as ${installdir}/${pop_auth} " \
+ ${INSTALL} -s -m 0755 -o root popper ${libexecdir}/qpopper
+ @echo "Installed popper as ${libexecdir}/qpopper"
+ @if [ "x${pop_auth}" != "x" ]; then \
+ ${INSTALL} -s -m 4755 -o ${apop_uid} -g ${BINGRP} ${pop_auth} \
+ ${sbindir}/q${pop_auth}; \
+ echo "Installed popauth as ${sbindir}/q${pop_auth} " \
"with uid ${apop_uid}"; \
- ${installdir}/${pop_auth} -init -safe; \
+ ${sbindir}/q${pop_auth} -init -safe; \
fi
clean: