pkgsrc/net/ucd-snmp-current/patches/patch-aa

64 lines
1.5 KiB
Text

$NetBSD: patch-aa,v 1.1.1.1 1999/09/22 21:11:39 kim Exp $
--- configure.in.orig Tue Aug 24 19:05:15 1999
+++ configure.in Wed Sep 22 11:04:16 1999
@@ -142,14 +142,16 @@
AC_ARG_WITH(libwrap,
[ --with-libwrap[=LIBPATH] Compile in libwrap (tcp_wrappers) support.],
- if test "x$withval" != "x" -a -d "$withval"; then
- WRAPLIBS="-L$withval -lwrap"
- elif test "x$withval" = "xyes"; then
- WRAPLIBS="-lwrap"
- else
- WRAPLIBS="$withval $LIBS"
+ if test "x$withval" != "xno"; then
+ if test "x$withval" = "xyes"; then
+ WRAPLIBS="-lwrap"
+ elif test "x$withval" != "x" -a -d "$withval"; then
+ WRAPLIBS="-L$withval -lwrap"
+ else
+ WRAPLIBS="$withval $LIBS"
+ fi
+ AC_DEFINE(USE_LIBWRAP)
fi
- AC_DEFINE(USE_LIBWRAP)
)
dnl This can't be within AC_ARG_WITH. I don't want to read autoconf m4
@@ -925,11 +927,7 @@
AC_CHECK_STRUCT_FOR([
#include <sys/types.h>
-#define KERNEL
-#define _KERNEL
#include <sys/socket.h>
-#undef KERNEL
-#undef _KERNEL
#include <net/route.h>
], rtentry, rt_dst, no)
@@ -940,11 +938,7 @@
dnl 4.4 compat
AC_TRY_COMPILE([
#include <sys/types.h>
-#define KERNEL
-#define _KERNEL
#include <sys/socket.h>
-#undef KERNEL
-#undef _KERNEL
#include <net/route.h>
],[
@@ -961,11 +955,7 @@
if test "x$ac_cv_RTENTRY_TYPE" = "x"; then
AC_TRY_COMPILE([
#include <sys/types.h>
-#define KERNEL
-#define _KERNEL
#include <sys/socket.h>
-#undef KERNEL
-#undef _KERNEL
#include <net/route.h>
],[
struct rtentry rt;