pkgsrc/geography/qgis/patches/patch-al
adam abd6bd9b66 Changes 1.7.3:
* Fix 3581 Ftools: union tool leave holes in output
* Fix 4500 Simplify tool freezes QGIS
* Fix 4466 Fixes for 'v.what.vect' and 'v.generalize' modules in the GRASS
  plugin
* Fix 4552 Patch for v.what.vect
* Fix 4035 Print Composer shape combo box not refecting current shape
* Partial Fix 3097 Add preference to set/override environment variables
* Fix 2749 Move 'Add to Attributes List' button
* Fix 4560 Wrong scale displayed in Map canvas
* Partial Fix 4383 Ftools: Improve how processes are handled
* Fix 3577 Adding a print composer doesn't dirty the document
* Fix 3170 Many GDAL Tools don't work in OS X standalone
* Fix 3723 Transparency settings are not applied from *.qml
* Fix 3576 qml not read automagically for rasters
* Fix 2977 Messy uninstallation of the standalone installer
* Union and Symetrical difference works only on whole layer fixed
* Save some time in node tool for geometry export and avoid detachs
* Initialize default symbol to 0 in rule based renderer
* Make relative paths default
* Fix tab restoration in project properties
* Add helpful info to GdalTools Settings dialog on how to configure GDAL path
* New vector layer dialog - show CRS as authid-description pair instead of
  proj4 string
* Fix crash with relative file paths if projPath is not yet defined
* Add helpful info to GdalTools Settings dialog on how to configure GDAL path
* And a lot of other smaller Bugfixes
2012-01-23 08:58:00 +00:00

15 lines
438 B
Text

$NetBSD: patch-al,v 1.2 2012/01/23 08:58:00 adam Exp $
--- src/plugins/grass/CMakeLists.txt.orig 2011-06-05 11:59:48.000000000 +0000
+++ src/plugins/grass/CMakeLists.txt
@@ -137,6 +137,10 @@ INCLUDE_DIRECTORIES(
qtermwidget
)
+IF (UNIX)
+ SET_TARGET_PROPERTIES(grassplugin PROPERTIES LINK_FLAGS "-L${GRASS_PREFIX}/lib -Wl,-rpath,${GRASS_PREFIX}/lib")
+ENDIF (UNIX)
+
TARGET_LINK_LIBRARIES(grassplugin
qgisgrass
qgis_gui