editors/xemacs editors/xemacs-nox11 The latter is now just editors/xemacs built with a specific set of options. Changes include: + Add support for the following new options in options.mk: x11 Support X11 displays lucid Use Lucid widget set Also add commented out support for the following options for alternative widget sets: gtk GTK widgets motif Motif widgets xaw Athena widgets Note that USE_ATHENA, USE_GTK, and USE_MOTIF are legacy variables for the corresponding options. + Remove Makefile.common and move all logic into xemacs/Makefile and xemacs/options.mk. + Rename the "mule" PLIST variable to "canna", which more accurately reflects what is conditionally installed. + Include termcap.buildlink3.mk to properly deal with termcap/curses issues (xemacs needs termcap). Drop the --with-ncurses=no setting as the issue is handled by termcap.buildlink3.mk. + In xemacs/Makefile, we don't need separate EXTRACT_ONLY and EXTRA_FILES if we're actually going to extract all of those files all of the time. Just list them all in DISTFILES. + Be slightly more aware of ${X11_TYPE} == "modular" by not referring to ${X11BASE} in that case. + In patch-ak, directly substitute the local value of etcdir (``../etc/'') into src/Makefile.in.in. This allows for overriding etcdir via INSTALL_MAKE_FLAGS at install-time so that destdir-style installation will work. + Support DESTDIR installation by adding INSTALL_MAKE_FLAGS to override where files are installed during the install phase. + Honor PKGMANDIR. + Bump the PKGREVISION for xemacs and xemacs-nox11 to 4. Both packages now track and use the same PKGREVISION number.
45 lines
1.1 KiB
Text
45 lines
1.1 KiB
Text
$NetBSD: patch-ak,v 1.5 2008/04/24 15:32:15 jlam Exp $
|
|
|
|
--- src/Makefile.in.in.orig 2005-01-30 21:55:02.000000000 -0500
|
|
+++ src/Makefile.in.in
|
|
@@ -72,8 +72,8 @@ CPPFLAGS=@CPPFLAGS@
|
|
LDFLAGS=@LDFLAGS@
|
|
|
|
c_switch_all=@c_switch_all@
|
|
-ld_switch_all=@ld_switch_all@
|
|
-ld_libs_all=@ld_libs_all@
|
|
+ld_switch_all=@ld_switch_all@ @LDFLAGS@
|
|
+ld_libs_all=@ld_libs_all@ @LIBOSSAUDIO@
|
|
ld_dynamic_link_flags=@ld_dynamic_link_flags@
|
|
|
|
extra_objs=@extra_objs@
|
|
@@ -163,9 +163,9 @@ ldflags += -Wl,--script=s/cygwin.sc
|
|
|
|
#ifdef SOLARIS2
|
|
%.o : %.c
|
|
-#else
|
|
-.c.o:
|
|
+ $(CC) -c $(cflags) $<
|
|
#endif
|
|
+.c.o:
|
|
$(CC) -c $(cflags) $<
|
|
|
|
## Create preprocessor output (debugging purposes only)
|
|
@@ -329,7 +329,7 @@ othersrcs = $(otherobjs:.o=.c)
|
|
LIBES = $(lwlib_libs) $(malloclib) $(ld_libs_all) $(lib_gcc)
|
|
|
|
#ifdef I18N3
|
|
-mo_dir = ${etcdir}
|
|
+mo_dir = ../etc/
|
|
mo_file = ${mo_dir}emacs.mo
|
|
#endif
|
|
|
|
@@ -658,7 +658,7 @@ libextcli_Xlib.so.1: ${external_client_x
|
|
#endif /* EXTERNAL_WIDGET */
|
|
|
|
config.h: ${srcdir}/config.h.in
|
|
-Emacs.ad.h: ${srcdir}/${etcdir}Emacs.ad
|
|
+Emacs.ad.h: ${srcdir}/../etc/Emacs.ad
|
|
|
|
config.h sheap-adjust.h paths.h Emacs.ad.h :
|
|
@echo "The file $@ needs to be re-generated."
|