34 lines
1.5 KiB
Text
34 lines
1.5 KiB
Text
$NetBSD: patch-ak,v 1.1 2010/07/31 19:14:08 dholland Exp $
|
|
|
|
Disable the extra symlinks like in src/gmxlib/Makefile.in; this makes
|
|
the install behavior uniform for all the libraries.
|
|
|
|
Note that if re-enabled the references to "libdir" below need DESTDIR
|
|
affixed, or it'll blow up if USE_DESTDIR is set.
|
|
|
|
|
|
--- src/tools/Makefile.in.orig 2009-12-06 21:18:54.000000000 +0000
|
|
+++ src/tools/Makefile.in
|
|
@@ -1407,14 +1407,14 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
|
|
# link the mpi library to non-mpi names if the latter are not present
|
|
-install-exec-hook:
|
|
- libname="libgmxana@LIBSUFFIX@"; \
|
|
- nompi="`echo $$libname | sed -e 's,_mpi,,'`"; \
|
|
- libdir="$(libdir)"; \
|
|
- if echo $$libname | grep mpi >/dev/null ; then \
|
|
- (cd $$libdir && test -e $$libname.a -a ! -e $$nompi.a && $(LN_S) $$libname.a $$nompi.a ; exit 0); \
|
|
- (cd $$libdir && test -e $$libname.so -a ! -e $$nompi.so && $(LN_S) $$libname.so $$nompi.so ; exit 0); \
|
|
- fi;
|
|
+install-exec-hook: ;
|
|
+# libname="libgmxana@LIBSUFFIX@"; \
|
|
+# nompi="`echo $$libname | sed -e 's,_mpi,,'`"; \
|
|
+# libdir="$(libdir)"; \
|
|
+# if echo $$libname | grep mpi >/dev/null ; then \
|
|
+# (cd $$libdir && test -e $$libname.a -a ! -e $$nompi.a && $(LN_S) $$libname.a $$nompi.a ; exit 0); \
|
|
+# (cd $$libdir && test -e $$libname.so -a ! -e $$nompi.so && $(LN_S) $$libname.so $$nompi.so ; exit 0); \
|
|
+# fi;
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|