pkgsrc/graphics/resize_image/patches/patch-aa
dsainty b9192a06bb Remove a portion of patch-aa that patched in a reference to
BUILDLINK_PREFIX.jpeg, which probably never worked, and should be entirely
unnecessary.
2010-12-18 08:15:51 +00:00

42 lines
1.5 KiB
Text

$NetBSD: patch-aa,v 1.2 2010/12/18 08:15:52 dsainty Exp $
--- Makefile.orig 2002-08-08 20:13:01.000000000 +0900
+++ Makefile 2003-09-11 06:40:40.000000000 +0900
@@ -1,17 +1,17 @@
# compilateur utilisé
-CC = gcc -O2 -DUNIX -Wall -g
+#CC = gcc -O2 -DUNIX -Wall -g
# compilateur utilisé quand une forte optimisation est nécessaire
-CC_OPT = gcc -O6 -DUNIX -Wall -g
+#CC_OPT = gcc -O6 -DUNIX -Wall -g
# répertoire on seront placés les fichiers .o
OBJ_DIR = obj
# tout les repertoires a rajouter dans le PATH utilise pour les includes
INCLUDE_PATH = -Iimage -Iutils
# tout les repertoires a rajouter dans le PATH utilise lors du linkage
LIBRARY_PATH =
# toutes les bibliotheques a utiliser au linkage
-LIBRARY = -lm -ljpeg
+LIBRARY = $(LDFLAGS) -lm -ljpeg
############################################################
# pour le programme final (le linkage)
@@ -38,14 +38,14 @@
include image/Makefile
resize_image : $(OBJ_DIR)/resize_image.o $(IMAGE_OBJS) $(UTILS_OBJS)
- $(CC) $(OBJ_DIR)/resize_image.o $(IMAGE_OBJS) $(UTILS_OBJS) $(LIBRARY_PATH)\
+ $(CC) $(CFLAGS) $(OBJ_DIR)/resize_image.o $(IMAGE_OBJS) $(UTILS_OBJS) $(LIBRARY_PATH)\
$(LIBRARY) -o $@
############################################################
# pour le programmes de demonstration
$(OBJ_DIR)/resize_image.o : resize_image.c $(IMAGE_H) $(UTILS_H)
- $(CC) -c resize_image.c -o $@ $(INCLUDE_PATH)
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c resize_image.c -o $@ $(INCLUDE_PATH)
############################################################
# pour faire le ménage