pkgsrc/cad/fasthenry/patches/patch-ac
dmcmahill ab8490f3bf - homepage has moved
- distfile has moved
- license has changed.  Patches are the result of de-fuzzing the
  old patches since the new source files have the new (less restrictive)
  license.
2004-09-20 02:08:58 +00:00

22 lines
645 B
Text

$NetBSD: patch-ac,v 1.3 2004/09/20 02:08:58 dmcmahill Exp $
--- src/fasthenry/Makefile.default.orig Tue Nov 12 19:18:58 1996
+++ src/fasthenry/Makefile.default
@@ -1,4 +1,4 @@
-CFLAGS = -O -DFOUR
+CFLAGS += -DFOUR
SHELL = /bin/sh
RM = /bin/rm
@@ -22,8 +22,10 @@ HEADER = induct.h cmplx.h resusage.h
MULHEAD = mulStruct.h mulGlobal.h patran.h resusage.h
NONUNIHEAD = gp.h
+LIBS?= -lm
+
fasthenry: $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB)
- $(CC) -o fasthenry $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB) -lm
+ $(CC) -o fasthenry $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SPLIB) $(LIBS)
mv fasthenry $(BIN)/fasthenry
$(SPLIB):