pkgsrc/cad/qcad/patches/patch-ad
dmcmahill 6428b177fd Instead of hardcoding 'gcc' as the c++ compiler (not g++ but gcc), use
AC_PROG_CXX to find a c++ compiler.  This fixes building with sunpro.
The result seems to run ok.  Patches submitted upstream.
2007-01-16 17:13:37 +00:00

16 lines
514 B
Text

$NetBSD: patch-ad,v 1.4 2007/01/16 17:13:37 dmcmahill Exp $
Use a c++ compiler for c++ code instead of hardcoding gcc as a c++
compiler. Reported to ribbonsoft [2007-01-16 dmcmahill].
--- fparser/Makefile.in.orig 2005-11-22 06:47:11.000000000 -0500
+++ fparser/Makefile.in
@@ -25,7 +25,7 @@ INCDIR = $(DESTDIR)/$(PREFIX)/include/fp
SHELL = /bin/sh
CC = @CC@
-CXX = gcc
+CXX = @CXX@
CFLAGS = -I./src @CFLAGS@ @DEFS@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@