8b563c8055
Pict is a language in the ML tradition, formed by adding a layer of convenient syntactic sugar and a static type system to a tiny core. The current release includes a Pict-to-C compiler, reference manual, language tutorial, numerous libraries, and example programs. The core language - an asynchronous variant of Milner, Parrow, and Walker's pi-calculus - has been used as a theoretical foundation for a broad class of concurrent computations. The goal in Pict is to identify high-level idioms that arise naturally when these primitives are used to build working programs - idioms such as basic data structures, protocols for returning results, higher-order programming, selective communication, and concurrent objects. The type system integrates a number of features found in recent work on theoretical foundations for typed object-oriented languages: higher-order polymorphism, simple recursive types, subtyping, and a powerful partial type inference algorithm.
28 lines
784 B
Text
28 lines
784 B
Text
$NetBSD: patch-ad,v 1.1.1.1 2009/10/28 06:13:40 dholland Exp $
|
|
|
|
DESTDIR support.
|
|
|
|
--- Pict/Makefile~ 1998-03-22 18:27:14.000000000 -0500
|
|
+++ Pict/Makefile 2009-10-23 23:36:18.000000000 -0400
|
|
@@ -6,7 +6,7 @@ PIFLAGS += -reset lib
|
|
|
|
all:: pict
|
|
|
|
-$(INSTALLDIR)/% : % Makefile ../SiteSpecific
|
|
+$(DESTDIR)$(INSTALLDIR)/% : % Makefile ../SiteSpecific
|
|
@echo Generating $@
|
|
@rm -f $@
|
|
@echo '#!/bin/sh' >$@
|
|
@@ -27,9 +27,9 @@ $(INSTALLDIR)/% : % Makefile ../SiteSpec
|
|
@echo exec $(INSTALLLIB)/$< $$'*' >>$@
|
|
@chmod 755 $@
|
|
|
|
-install:: all $(INSTALLDIR)/pict
|
|
- cp -f pict $(INSTALLLIB)
|
|
- chmod 755 $(INSTALLLIB)/pict
|
|
+install:: all $(DESTDIR)$(INSTALLDIR)/pict
|
|
+ cp -f pict $(DESTDIR)$(INSTALLLIB)
|
|
+ chmod 755 $(DESTDIR)$(INSTALLLIB)/pict
|
|
|
|
ifneq ($(wildcard *.ml),)
|
|
|