pkgsrc/audio/amp/patches/patch-af
dholland 5cde6ea707 Don't use -O6, clang doesn't like it and it doesn't mean anything to gcc
either. Stick to -O3. While here, sync the patches for configure and
configure.in, and give it the ability to recognize OpenBSD as well.
(which might or might not work)
2011-09-04 01:39:21 +00:00

25 lines
768 B
Text

$NetBSD: patch-af,v 1.3 2011/09/04 01:39:21 dholland Exp $
--- configure.orig 1997-08-23 11:11:24.000000000 +0000
+++ configure
@@ -1398,7 +1398,7 @@ case "$OS_TYPE" in
DEFINES="-DOS_$OS_TYPE -DARCH_$ARCH_TYPE"
;;
- Linux|FreeBSD)
+ Linux|FreeBSD|NetBSD|OpenBSD|DragonFly)
CC="gcc"
if test "$ARCH_TYPE" = "i486" ; then
CFLAGS_ARCH="-m486"
@@ -1409,7 +1409,10 @@ case "$OS_TYPE" in
if test "$OS_TYPE" = "FreeBSD" ; then
OS_TYPE="BSD"
fi
- CFLAGS="-O6 -ffast-math -fomit-frame-pointer ${CFLAGS_ARCH}"
+ if test "$OS_TYPE" = "DragonFly" ; then
+ OS_TYPE="BSD"
+ fi
+ CFLAGS="-O3 -ffast-math -fomit-frame-pointer ${CFLAGS_ARCH}"
DEFINES="-DNO_BYTE_SWAPPING -DOS_$OS_TYPE -DARCH_$ARCH_TYPE"
;;