pkgsrc/devel/xulrunner192/patches/patch-mm
tnn ff57234978 Re-import previous version of Firefox, because firefox-4.0 won't
work for some users (sparc64 support, for example, is busted and
won't appear again until firefox-5.0).
2011-04-19 11:16:02 +00:00

29 lines
802 B
Text

$NetBSD: patch-mm,v 1.1.1.1 2011/04/19 11:16:08 tnn Exp $
Don't link with -lCstd on Solaris when using GCC. From Tim Zingelman.
part of PR pkg/39085
--- toolkit/library/Makefile.in.orig 2011-02-18 18:33:39.000000000 +0000
+++ toolkit/library/Makefile.in
@@ -253,13 +253,20 @@ EXTRA_DSO_LDOPTS += -lbe -ltracker
endif
ifeq ($(OS_ARCH),SunOS)
-EXTRA_DSO_LDOPTS += -lelf -ldemangle -lCstd
+EXTRA_DSO_LDOPTS += -lelf -ldemangle
+ifndef GNU_CC
+EXTRA_DSO_LDOPTS += -lCstd
+endif
endif
ifeq ($(OS_ARCH),AIX)
EXTRA_DSO_LDOPTS += -bbigtoc
endif
+ifeq ($(OS_ARCH),NetBSD)
+EXTRA_DSO_LDOPTS += -lossaudio
+endif
+
ifeq ($(OS_ARCH),WINNT)
EXTRA_DSO_LDOPTS += $(call EXPAND_LIBNAME,shell32 ole32 uuid version winspool comdlg32 imm32 winmm wsock32 msimg32)
ifneq (,$(MOZ_DEBUG)$(NS_TRACE_MALLOC))