pkgsrc/x11/kdelibs3/patches/patch-ad
markd 2afa4ad7ff Update to KDE 3.5.6
KHTML
* Treat specific attribute values case-insensitively during style matching.
  With these changes, KHTML becomes the first rendering engine to thoroughly
  pass the 578 tests of the excellent Automated CSS3 Selectors Testsuite
  (http://www.css3.info/selectors-test).
* Implement CSS3 extension text-overflow: ellipsis.
* Implement overflow-x/y as many websites use it now.
* Fix overflow sometimes not painted/repainted.
* Fix incorrect margin for some tables.
* Fix crashes on some AJAX pages.
* Fix background no-repeat image wrapping.
* Fix instanceof ecma operator not working on DOM objects.
* Fix some pages appearing empty or missing content.
* Fix table caption rendering on some pages.
* Make innerText much faster fixing freezes on some web pages.
* Fix crash on javascript manipulated tables.
* Fix all links gettinh underlined while hovering over just one link on
  some malformed web pages.
* Let floats overflow the left border when they should.
* Fix cursor in input field not disappearing when setting focus to another
  input field.
* Prevent crash-inducing recursion of detach due to blur events happening
  when widgets with focus get destroyed.
* Fix border collapse not working in tables.
* Fix ∉ displayed as ¬in;.
* Make max-height and max-width: none work correctly.
* Fix memory leak when using deleteRule.
* Fix crash when resolving a stylesheet imported from external one.
* Fix an infinite relayout on msdn.
* Fix computed line-height beign incorrect.
* Fix crash race on various sites with popup ads.
* Reset hover text when mouse leaves khtml view.
* Whenever the content changes, recheck if the mouse cursor shall show
  some other shape to correctly match it to the content below it.
* Immediately redraw visited links with the respective color when the
  page got loaded and inserted into the history.
* Fix tables sometimes intruding floats on dynamic restyle.
* Fix conflicting priorities in font shorthand parsing leading to wrong
  line-height computation.
* Do not crash when finding backwards.
* Fix infinite recursion happening when changing style from
  overflow:scroll to auto.
* Fix initial size of input type=FILE form control.
* Make vertical-align text-top/bottom CSS 2.1 compliant.
* Fix ecma alert() dialog formatting it's output as a single huge line
  without line breaks.

Kate
* Add actionscript highlighting.
* Add some pseudo-elements that khtml supports, but FireFox doesn't.
* Fix wrong indentation at top of source file in cstyle indenter.
* Fix memory leaks and accessing uninitialized variable.
* Fix endless loop in cstyle indenter.
* Fix crash using comment commands.
* Java Highlighting: Correctly highlight comments after import lines.

kdefx
* Change asterisks on passwords to bullets.

kdeprint
* Fix printing of files with accentuated characters in filename or in
  the path.
* Fix showing names of non local files in kprinter.

kio
* Don't crash when creating a job for an invalid URL.
* Hide the progress dialog while displaying the password dialog.
* Fix wrong "Couldn't receive DCOP signal" errors on RMB menu.
* Fix statusbar having more than one line.
* Fix possible data loss when using kioexec.

KJS
* Properly propagate some exception values.
* Fixed Number.toPrecision(n) calls on negative zero.
* Allow changing the internal value of invalid dates.
* Fix Unicode support in RegExp handling, and also be more robust
  vs. embedded nulls. Fixes problems with some cyrillic characters in
  gmail and makes google calendar somewhat work.
2007-01-26 02:44:27 +00:00

15 lines
608 B
Text

$NetBSD: patch-ad,v 1.11 2007/01/26 02:44:28 markd Exp $
dont install hicolor/index.theme as hicolor-icon-theme pkg will
--- pics/Makefile.in.orig 2007-01-19 15:41:52.000000000 +1300
+++ pics/Makefile.in
@@ -515,7 +515,7 @@ x_libraries = @x_libraries@
xdg_appsdir = @xdg_appsdir@
xdg_directorydir = @xdg_directorydir@
xdg_menudir = @xdg_menudir@
-SUBDIRS = . hicolor crystalsvg emoticons
+SUBDIRS = . crystalsvg emoticons
INCLUDES = $(LIBART_CFLAGS) -I$(top_srcdir)/kdecore/svgicons -I$(top_srcdir)/kdefx $(all_includes)
@include_SVGICONS_TRUE@KSVGTOPNG = ksvgtopng
ksvgtopng_SOURCES = ksvgtopng.cpp