pkgsrc/audio/tremor-tools/patches/patch-ac
chris 818967d985 Conversion of ogg123 to use the tremor library. This makes my arm boxen
capable of decoding ogg vorbis files in real time.

Note this package produces one binary: igg123, which is compatible with ogg123.
2002-09-24 09:35:15 +00:00

48 lines
1.4 KiB
Text

$NetBSD: patch-ac,v 1.1.1.1 2002/09/24 09:35:17 chris Exp $
--- ogg123/Makefile.am.orig Sat Sep 14 19:28:28 2002
+++ ogg123/Makefile.am Sat Sep 14 19:29:02 2002
@@ -2,9 +2,7 @@
AUTOMAKE_OPTIONS = foreign
-mans = ogg123.1
-docs = ogg123rc-example
-ogg123sources = audio.c buffer.c callbacks.c \
+igg123sources = audio.c buffer.c callbacks.c \
cfgfile_options.c cmdline_options.c \
file_transport.c format.c http_transport.c \
ogg123.c oggvorbis_format.c playlist.c \
@@ -21,26 +19,23 @@
localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
-bin_PROGRAMS = ogg123
+bin_PROGRAMS = igg123
docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
mandir = @MANDIR@
INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@ @AO_CFLAGS@ @CURL_CFLAGS@ \
@PTHREAD_CFLAGS@ @SHARE_CFLAGS@ @I18N_CFLAGS@
-ogg123_LDADD = @SHARE_LIBS@ \
- @VORBISFILE_LIBS@ @VORBIS_LIBS@ @OGG_LIBS@ @AO_LIBS@ \
+igg123_LDADD = @SHARE_LIBS@ \
+ @IVORBISFILE_LIBS@ @VORBIS_LIBS@ @OGG_LIBS@ @AO_LIBS@ \
@SOCKET_LIBS@ @LIBICONV@ @CURL_LIBS@ @PTHREAD_CFLAGS@ \
@PTHREAD_LIBS@ @I18N_LIBS@
-ogg123_DEPENDENCIES = @SHARE_LIBS@
-ogg123_SOURCES = $(ogg123sources)
-
-man_MANS = $(mans)
-doc_DATA = $(docs)
+igg123_DEPENDENCIES = @SHARE_LIBS@
+igg123_SOURCES = $(igg123sources)
endif
-EXTRA_DIST = $(ogg123sources) $(mans) $(docs)
+EXTRA_DIST = $(igg123sources)
debug: